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Training Guide Use 
This guide is a supplement to the training session. While, it includes examples of several techniques, 
we tailor each training session to the needs of the students attending. Therefore, the trainer may use 
different examples.  

 

 

Student Manager Demo 
This guide is meant to be used with a current copy of the Student Manager Demo. Examples and 
exercises use records from the demo dataset.  

We suggest you download a current demo before using the training guide. You can download the 
demo on our ACEware website: 

 https://www.aceware.com/demos/sm.shtml 

 

 

Trademark 
ACEware Systems, Inc.™, Student Manager™, ACEweb™, are trademarks of ACEware Systems, 
Inc. in the U.S.A. and other countries. Microsoft, Word, Excel and Windows are registered 
trademark of Microsoft Corporation. Other brands and their products are trademark or registered 
trademarks of their respective holders and should be noted as such. 

Information in this document is subject to change without notice. The software described in this 
document is furnished under a license agreement or nondisclosure agreement. The software may be 
used or copied only in accordance with the terms of those agreements. No part of this publication 
may be reproduced, stored in a retrieval system, or transmitted in any form or any means electronic 
or mechanical, including photocopying and recording for any purpose other than the reproduction 
for licensed users without the written permission of ACEware Systems, Inc. 

 

 

Terms of Use 
All items, including but not limited to the design, structure, and arrangement of this guide are owned 
by ACEware Systems, Inc. and is protected by copyright and trademark laws. 

You may use information in this guide as a resource for training purposes.  

You may not use this guide for any purpose that is unlawful or prohibited by these Terms of Use, 
or to solicit the performance of any illegal activity or other activity which infringes the rights of 
ACEware Systems, Inc. or others. 
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UNIT 1 

INTRODUCTION TO STUDENT MANAGER 
 

 

Unit Objectives 

In this unit, you will learn to: 

● Start Student Manager 

● Log in 

● Use the Navigation Tools 

● View/Edit User Information 

● Access Help 

● View/Edit Preferences 

● Add/Edit Codes 
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Opening and Logging into Student Manager 
Double-click the icon on the computer's desktop to start Student Manager: 
 
For this training session, enter the following User ID and Password:  
 
 

User ID: ACE 

Password: ACE 
 
Checking the Remember Me on This Computer saves your 
credentials so you don’t need to enter your credentials when 
starting Student Manager.  

Note: this user name and password is only used when accessing the training system. When you log 
into your organization’s system (i.e. at your workstation), you will enter the user name and password 
your Student Manager administrator gave you.  

Student Manager Main Menu 
Access the following from the Student Manager Main Menu:  

● File – Create and Find records, Save changes to current record, and Exit Student Manager. 

● Edit – Undo, Copy, Edit, Paste, Clone and Paste Name record, Preferences and User Profile. 

● Module - Access Names, Course, Registration, Firms, Zip Codes, Locations, Holidays, and 
Optional modules. 

● Reports - Run reports. 

● Tools - Import/Export Reports (Report Tools), Browse databases (Database Admin), 
Set/Remove filters, Import/Export data, Update Counts, Manage Credit Cards, Set up Users 
(Password Maintenance), and check for Callbacks and Reminder Notes. 

● Help - Access Help, Technical Support Information, the Student Manager website, and Student 
Manager System information (About Student Manager).  

Student Manager Toolbar 
Perform the following actions from the Student Manager Toolbar: 

 

 

 

 

 

Edit Preferences Lookup All Courses 
Lookup Faculty 

Add Name Log on New User 

Lookup All Names 
Lookup Registrations 

Online Reference Guide 

Add/Edit Codes Favorite Reports 

New Features 
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Student Manager Quick Launch 
Perform common actions from the Quick Launch 
screen. 

 Add a Name record 
 Lookup an Active Name record 
 Lookup an Active Course record 
 Lookup Registrations 
 Access Favorite Reports 
 Add/Edit Codes 
 Edit Preferences 
 Lookup Faculty records 
 Access Help 
 

Module Buttons 
 

 -- Moves to the first record of the database.* 

 -- Moves to the next record.* 

 -- Moves to the previous record.* 

 -- Moves to the last record of the database.* 

 -- Create a new record.* 

 -- Saves any edits you have made. 

 -- Undo any edits made since your last save. 

 -- Marks the record for deletion. 

 -- Locates a specific record from the database.* 

 -- Cancels any edits and closes the screen.** 

 -- Saves edits and closes the screen.* 

*Changes are saved to the record before navigating to the next record or closing the screen. 

**Closes the screen WITHOUT saving any changes made to the record. 

Keyboard Conventions 
● Press the Alt key + the underlined letter to activate menu items or buttons (e.g. Alt+F opens 

the File Menu) 

● Press the Esc key to close windows without navigational buttons or to escape without saving. 

● Move forward through fields by pressing the Tab key. 

● Move backward to fields by pressing the Shift + Tab keys. 

For a complete list of keyboard shortcuts, see Appendix A. 
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Mouse Conventions 
● Select Menu items and Buttons with one click of the mouse button.  

● Remove assessed items (e.g. Interest codes assigned in a Name record) from windows by double 
clicking with the mouse button. 

Viewing/Editing User Information 
You can view and edit, your User Information by selecting Edit > My User Profile. Your user 
information is used in reports and in emails sent within Student Manager. 

Note: you can store messages in the Alt+F3, F4, or F5 fields that can be recalled into a Student 
Manager field/query by using the appropriate shortcut key.  

Accessing Help 
Student Manager provides you with an Online Reference Guide to help you make the most of the 
program. You access the Guide from within Student Manager in one of the following ways: 

✓ Click the Help icon on the Student Manager Toolbar. 

✓ Click the Help icon on the Student Manager Quick Launch. 

✓ Select Help > Help 

The Online Reference Guide will open in your web browser.  

Student Manager Preferences 
Determine what fields you will use and behavior options for the various modules from the Student 
Manager Preferences screen. You can access Student Manager Preferences in one of these two ways: 

✓ Click the Preferences icon on the Student Manager Toolbar. 

✓ Click the Edit Preferences icon on the Student Manager Quick Launch. 

✓ Select Edit > Preferences.  

Preferences are grouped on tabs. Preferences on the tabs are color-coded: 

● Black - are user specific (they affect the user only).  

● Blue - are global (effect every user). You must have level 6 access to edit preferences in blue. 

● Purple - require a security level 6 to change--AND the user must be a level 6 in the particular 
area to use the option (e.g. user must have a level 6 in Pay to edit receipt numbers). 

Note: your Student Manager Administrator can dis-allow your ability to edit preferences. If your 
Preferences icon is grayed out (on your own system at your organization), you don't have rights to 
edit your preferences. Please see your Student Manager administrator for more information.  
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Student Manager Codes 
Garbage in - garbage out has become a computer cliché. It refers to collected data that becomes 
worthless if there is no coordination of how data is entered into the database. To combat this 
problem, Student Manager uses data validation tools to ensure information conforms with rules set 
up for specific data elements. Some of these rules are built into Student Manager: 

● You cannot enter an invalid date such as April 31st. 

● Each name record must have a unique ID number. 

● Each course record must have a unique Course Code. 

● A course must exist in the database before you can register anyone in the course. 

● A registration must exist in the database before you can make a payment to the registration. 

● Codes for validated fields must be defined (added to the field's Code list) before they can be 
used in records. 

Field Validation 

Many of the fields in Student Manager are 
automatically validated. Most of the validated 
fields have drop down menus from which you 
select the appropriate code (access menu with the 
Down Arrow button to the right of the appropriate 
field):  

 
Other validated fields have purple hash marks 
to the right of the field (Firm field in this 
example). These are usually fields which have 
too many codes to display in a drop down 
menu). In these fields, you type in the code 
then tab out of the field.  

 
The system checks the Data Validation list and if 
the code does not exist, you are given the 
opportunity to add a new code. E.g. if entering a 
firm that is not in your Firms database.  

 
 
 
Some fields offer optional validation (e.g. Department field on Course, Salutation on Names). 
Validation will only occur in these fields if the Validate option is enabled. Enable data validation in 
these fields on the module's Preferences tab. 

Most codes are added/edited on the Codes screen. You can access the screen in the following ways:  

✓ Click the Add/Edit Codes icon on the Student Manager Toolbar. 

✓ Click the Add/Edit Codes icon on the Student Manager Quick Launch. 

✓ Select Module > Codes.  
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To edit a code, select the code type from the Code Type drop down list.  

 
Once you select the code type, you can click the FIND button to select a specific code for that code 
type, or click the Add button to add a new code for the code type.  

Note: you can also add a new code for a specific code type from the module record by clicking the 
Plus sign [+] button next to the appropriate field. This opens the CODES screen for the particular 
code. You are already placed in 'Add' mode so enter the Code and Description in the appropriate 
fields then click the OK/CLOSE button to save the new code and close the CODES screen. The new 
code will now be available in the Code list (drop down menu). 

 

Other Codes 

Codes not added/edited on the Codes screen are accessed in these ways: 

✓ Locations – Module > Locations. 

✓ Holiday Dates – Holiday Dates are technically not codes but the system takes them into account 
when calculating course ending dates and room scheduling so they must be set up before you 
schedule a course. Add/edit Holiday Dates from Module > Holidays.  

✓ Catalog Codes – Module > Catalog > Catalog Codes 

✓ Firms – Module > Firms 

✓ Zip Codes – Module > Zip Codes  
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UNIT 2 

ADDING/EDITING COURSES 
 

 

Unit Objectives 

In this unit, you will learn to: 

● Look up course records 

● Add course records 

● Clone course records 

● View/Customize Room Use records 

● Change Course Status 

● View/Edit Course Type 

● Print Course Quick Reports 
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Looking Up Courses 
Look up courses in any of the following ways:  

✓ Click the Lookup Active Course icon on the Quick Launch screen. 

✓ Click the Lookup Course icon on the Student Manager Toolbar. 

✓ Select File > Find > Courses or Module > Courses > Find Course 

✓ Press Alt+J 

Exercise: find and open the 
24FACE010A course. 

Finding Record 
Type a search term and the system will return records 
containing your search term in the Search Key fields. 

Date Search: enter the date in mm/dd/yy format. You can 
also enter a partial date, e.g. 06/02 (June 2nd).  

Opening Record 
Double-click the entry or press the Tab key to move from 
the Search field to the list of records, use your arrows to 
scroll to the one you want, and hit enter. 

Course Screen 
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The COURSE screen consists of 7 tabs:  

● Main Tab – Course information such as Code, Title, Location, Start Time, # of Sessions, is 
entered on this tab. 

● Additional Info Tab – Registration Times, Email Attachment, Alternate Course Display Code, 
Person to Notify and Course User Defined Fields are entered on this tab. 

● Fees Tab – Main registration fees and Other fees tab (i.e. Optional fees, Mandatory fees, coupon 
codes (ACEweb) and Inventory Items) are set up on this.  

● Instructors – Course instructors are assigned on this tab. You can also set pay details, 
presentation notes, and evaluation codes. 

● Comments Tab – Course notes are entered on this tab such as notes that will print on receipts, 
internal notes, and registration warning messages. 

● ACEweb Info Tab – ACEweb options are set on this tab such as Web display properties, 
Workshop minimums, special pages, etc.  

● Hybrid Tab – number of physical seats and virtual notes are entered on this tab.  

Adding A New Course Record 
To add a new course record: 

✓ Select File > New > Course 

✓ Select Module > Courses > Add Course 

✓ If the COURSE screen is open, click the ADD button.  

EXERCISE: create a new course record:  

1. Enter the following in the appropriate fields:  

Course Code 24FPRGMNG Begin Date: 12102024 

Title Introduction to Programming #of Sessions 6 

Department Information Systems Days T, Th 

Subject Code COMPUTER Start Time 9 

Catalog PRGMNG St Time Min 00 

Account 21-10239 AM/PM AM 

Coord Havlicek End Time 11 

CEUS 2.4 E Time Min 45 

Hours 24 AM/PM AM 

Min 15 Building Nebraska Center 

Max 25 Rm 112 

Estimate 20 Check the Print On Receipt Box 

2. Click the SAVE button.  

When you save the record, the other tabs become available.  
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Adding Course Fees 

Select the Course Fees tab. Course Fees are divided into two categories:  

Main Fees – the main registration fee individuals pay when registering for a course. A course can 
have an unlimited amount of Main fees. However, a registrant can only be assessed one Main fee, 
i.e. the registration fee for which he/she qualifies.  

Other Fees – other fees associated with the course such as Lab fees, Parking fees, Textbook fees, 
etc. Other fees can also be set up as Mandatory. Mandatory fees are automatically assessed to a 
registrant when he/she enrolls in the course. A course can have an unlimited amount of Other fees, 
and registrants can be assessed an unlimited amount of Other fees.  

EXERCISE: add the following Main Fees:  

1. Select the Fees tab. 

2. Click the ADD MAIN FEE button. 

3. Select Early Bird Fee from the Fee Description drop down menu. 

4. Enter 250.00 in the Amount field. 

5. Enter 30 in the Expires field. 

6. Click the ADD MAIN FEE button again to add another Main Fee: 

7. Select Registration Fee from the drop down menu. 

8. Enter 300.00 in the Amount field. 

EXERCISE: add the following Other Fees:  

1. Click the ADD OTHER FEE button. 

2. Select Book from the Fee Description drop down menu. 

3. Enter 55.00 in the Amount field. 

4. Select Yes in the Mandatory column. 

5. Click the ADD OTHER FEE button to add another Optional Fee: 

6. Select Calculator drop down menu. 

7. Enter 45.00 in the Amount field. 

Deleting Fees 
To mark a fee for deletion:  

1. Select the fee you want to delete.  

2. Click on the White box to the left of the Fee Description field. This will turn the box Black.  

3. Click the SAVE button to save your changes.  

Un-delete Fee 
To un-delete the Fee, click the box to turn it white again.  
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Adding Instructor(s) 

Select the Instructors tab.  

EXERCISE: assign the following instructor to the course:  

1. Select the Instructors tab.  

2. Click the Plus Sign [+] button to the left of the Current Instructor field to select an instructor. 

3. Select Bill Clark from the list. 

4. Select the Per Class Session pay type. 

5. Enter 200.00 in the Pay rate field. 

Assigning Another Instructor 
To assign another instructor to the course, click the Plus Sign [+] button again and select the 
instructor. Each instructor will have his/her own payment/presentation record. To view a specific 
instructor’s information, select the appropriate instructor from the Current Instructor list.  

Adding Course Notes 

Select the Comments tab. There are three types of Course Comments:  

● Registration Warning Message - notes entered in this field will pop up whenever you register 
an individual in the course (useful for notifying registration staff of special instructions or 
requirements).  

● Note (May be printed on receipt) - include notes that you want to print on registration 
receipts (useful to notify individuals of special instructions, such as a reminder to bring 
course materials to the first class).  

● Comments (Reminder Note) - notes for yourself or another user, such as the date the catering 
order should be submitted.  

EXERCISE: add the following course notes: 

1. Enter Bring supervisory manual to first class in the Notes (may be printed on receipt) field. 

2. Enter Order coffee and rolls from caterer on the Comments (Reminder Note) field. 

3. Enter ACE in the Remind field. 

4. Enter tomorrow’s date in the Date field. 

5. Click the SAVE button to save your changes to the course record.  

NOTE: We’ll utilize this course record throughout the exercises in this guide.  
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Cloning Courses 
Cloning a course allows you to copy the information from a course record into a new course record 
(including fees, location, instructor, notes). All you’ll need to do is change the course code (e.g. 
change the semester or section characters) and enter the dates of the new course. To clone a course:  

1. Look up the 24FPRGMNG course. 

2. Click the CLONE COURSE button.  

3. Enter the new course code: 24WPRGMNG. Then click the OK button. 

4. The system creates a course record with the new course number and copies the information from 
24FPRGMNG into it. All you will need to do is enter the Begin date and select days of week.  

5. Change the Begin Date to: 01072025 

6. Click the SAVE button. 

Viewing/Customizing Room Use Records 
When the course is created, the system creates a room use record for each session. To view the room 
use records, click the ROOM USE button.  

Course Room Use records are customizable. You may change the Session Date, Start Hour, Start 
Min, End Hour, End Min, and Location of each session. For instance, you may need to schedule one 
session at a different location or change the meeting time of a session. 

To customize the Room Use records: 

1. Open the course record. 

2. Click the ROOM USE button to open the EDIT ROOM USE screen. 

3. Highlight the record you want to change. 

4. Make the necessary changes in the Date, Start, End, Building, and Room fields. 

5. Click the SAVE button to save your changes. 

6. Click the OK/CLOSE button to close the EDIT ROOM USE screen. 

Changing Course Status 
When you create a course record, it’s Active by default. Active courses are open for enrollment and 
appear in all registration routines.  

Other Course Status Options 
You also have the option of deactivating, canceling, and/or locking courses.  

Deactivating Courses - removes it from the active courses list when you register individuals from 
the regular registration routines. To deactivate a course, uncheck the Active box. 

You may still register individuals with the ADD/EDIT REGGIES button on the Course screen or 
from Module > Registrations > Add/Edit Registrations (by Course).  
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Canceling Courses - canceling a course removes the course from all Registration routines. In 
addition, canceled courses will not be included in most reports unless you specifically request to 
include canceled records in the report.  

To cancel a course that has no registrations, un-check the Active box then check the Canceled box. 
However, if the course has registrations, you must run the Cancel Course Wizard. We’ll discuss the 
Wizard in a later section. 

Locking Courses - locking a course restricts all users from making any changes to the course record, 
registrations, or payments. To lock a course, check the Locked field. Locking a course is useful for 
accounting purposes to lock records after a course has finished.  

Mass Update/Change 
Mass Update/Change allows you to deactivate or lock a series of courses. It also allows you to 
change web publish/register status, archive, assign fees, purge waitlists, and delete old room use 
records. To run Mass Update/Change: 

1. Select Module > Courses > Mass Change/Update/Delete/Archive to open the MASS 

UPDATE/CHANGE screen.  

2. Select the action you want to perform (e.g. deactivate courses, purge waitlists).  

3. Select courses beginning between dates and/or scope by course number.  

4. To preview the courses, click the PREVIEW button.  

5. Click the OK button to make the change. 

Viewing/Changing Course Type 
The Course Type is an internal code identifying the type of course. Course behavior is determined 
by the selected type. 

● Open – standard type course.  

● Pending – courses under development. Pending courses are automatically deactivated. 

● Online – adds the Date Opened for Enrollment field to the COURSE screen to set the date the 
course will be opened for enrollment (note: you don’t enter a Begin date on Online courses).  

● Membership – used with Membership option. 

● Donation – used with ACEweb's donation option.  

● Event – allows users to purchase multiple tickets.  

● Workshop (optional module) – create workshops for the course. The Workshop type does NOT 
allow multiple registrations. 

● Ind Study – only used with Independent Study Module.  

● Inventory – identifies a course record used for inventory. 

● Contract – private course (e.g. for employees of a specific company). 

● Package1 and Package2 – only available with course Packaging module. Identifies course as the 
parent of a package.  

● Hybrid - set up Hybrid courses where you have physical and virtual attendees. 
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Course Quick Reports 
The Course Quick Report button allows you to print rosters, name tags, mailing labels, certificates, 
course description, or faculty contracts for the particular course. 

EXERCISE: print a course quick report. 

1. Look up the 24SACE010A course record.  

2. Click the QUICK REPORTS button to open the QUICK REPORTS screen. 

3. Check the Name Roster box (if any other boxes are checked, un-check them). 

4. Click the OK button to preview/print the report.  

Notes:  

● The system will print all marked reports (checked ones), one right after the other.  

● If your organization has the Email module, you can also email rosters to instructors, email 
regular and waitlisted registrants from Quick Reports.  

● If the course has no registrations, you will only have the option to print class descriptions and 
faculty contracts. 

● If you want waitlisted registrants included in reports, you must check the Show waitlists (on 
rosters) box.  
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UNIT 3 

ADDING/EDITING NAMES 
 

 

Unit Objectives 

In this unit, you will learn to: 

● Look up name records 

● Add name records 

● Set Flag fields 

● Enter Call Backs 

● Keep Contact Log 

● Clone Names 

● Add Firms 

● Group Names 

● Print Name Quick Reports 
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Looking Up Name Records 
Look up Names in any of the following ways:  

✓ Click the Lookup Name icon on the Quick Launch screen.  

✓ Click the Lookup Names icon on the Student Manager Toolbar 

✓ Select File > Find > Names or Module > Names > Find Name 

✓ Press Alt+L 

When the STUDENT MANAGER SEARCH window opens, look up Cheryl Scott.  

Names Screen 

 
The NAMES screen consists of 5 tabs: 

● Main Tab - Individual's personal data such as Name, Address, Phone Numbers, etc. 

● Demographics – additional demographic data, flags to help with reports, membership 
information.  

● Comments/History Tab - Comments, Contact Log, Special Needs are entered on this tab. 

● Additional Info - Name User Defined Fields are entered on this tab. Contents of user defined 
fields can also be displayed on the Main tab (under Fee Category field).  

● Credential Tab - Credentials are multi-purpose records which allow you to track other 
information about the student such as courses from other sources and job placement information. 
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Adding a New Name Record 
To add a new Name record: 

✓ Click the ADD NEW NAME icon on the Student Manager Toolbar. 

✓ Select File > New > Name or Module > Names > Add New Name 

✓ Press Alt+A 

EXERCISE: create a new name record:  

1. Enter the following information:  

Salut Mr. ***IMPORTANT*** Most character fields are
automatically capitalized. Because of this we
STRONGLY discourage using CAPS LOCK when
entering data. 

First Adam 
Middle A 
Last Miller 
Suffix No suffix 
Address 1 1000 Any Lane  
Zip Code 66502  
Day 5553333  
Eve 5554444  
Email aamiller@imaginary.com  
Fee Category Senior Citizen *Set a default fee category for an individual's future

registrations. The individual will automatically be
assessed the fee--IF it has been set up in the course and
IF that fee is the lowest they qualify for.. 

Birthday 01/01/1980  
Sex M  

2. Click the SAVE button to save your new record. Note that the system assigns a computer 
generated ID to the record (in the SSN/ID field).  

Assigning Codes 

The Name Codes fields track how an individual heard of your program (Source), occupation 
(Occupation) and type of company (Organization), and interests (Interest).  

1. Enter the following Codes: 

Source FRIEND 
Occupation SALES 
Organization RETAIL 

2. To add Interest codes, click the ADD INTEREST button. Select the following Interest Codes 
(Ctrl+Click to select multiple codes), then click the OK button to add them to the record and 
return to the Names screen.  

Interest Code Market 
Interest Code Sales 

Note: to remove an interest code from a record, double-click the entry in the Interest Code window.  
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Flag Fields 

The Names screen offers the following flag fields to help with mass mailing and reporting needs: 

● Don't Mail Flag - check this field to identify individuals who don't want to receive mass 
mailings. 

● Excl Flag (Email Module Users Only) - check this field to identify individuals who don't want 
to receive mass emailings. 

● Label Flag - check this field to include the individual in one-time mailing lists or generate 
mailing labels for an eclectic (non-permanently defined) group. Note: an optional field, located 
just under the Label Flag, is also available to use in tandem with the Label Flag. In this field, 
you identify the type of mailing to send to the individual (e.g. brochure, catalog, flyer). 

● Report Label Flag - check this field (just above the Label Flag, see above) to include individuals 
in subsets of records for special reporting purposes. 

 
EXERCISE: check the Print Label Flag on Adam’s record then enter Brochure in the Label Info 
field.  

Note: we’ll see how the Print Label option works in the Reporting unit.  

Call Back System 

Student Manager offers a feature that will remind users to call individuals on a specific date. If 
enabled, the system will check for call backs during startup and display the call back list for that 
date. Scope the call backs by user and the system will only list the call backs for the particular user.  

1. Enter the current date in the Call Back date field. 

2. Click the OK/CLOSE button on the Maintain Names screen. 

3. Close Student Manager (File > Exit). 

4. Restart Student Manager. 

During Student Manager’s startup process, the system will check for call backs and display a list of 
call backs for you (if any).  

*Special Call Back Tool 
There is a *Special tool available that allows you to schedule a Call Back (for yourself) 10 days in 
the future. To use this tool, click the *SPECIAL button then click the CALLBACK button.  

Adding Comments 

Add comments about the individual, such as special needs or contact information on the 
Comments/History tab. This tab contains 3 fields into which you can enter comments:  

● Comments - internal notes about the individual.  

● Contact History - log contacts with individual (e.g. emails sent via Student Manager, phone 
calls, etc.).  

● Special Needs - an individual's special needs. Messages in this field will pop up when someone 
accesses the name record.  
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EXERCISE: add a comment to Adam's record. 

1. Enter Adam is hearing impaired in the Special Needs field.  

2. Click the OK/CLOSE button to save the changes and close the NAMES screen.  

3. Look up Adam’s record again--the message should pop up when the record opens.  

Contact Log 

Student Manager provides you with a tool that allows you to log your contacts with individuals. To 
use this tool: 

1. Select the Main tab. 

2. Click the *SPECIAL button 

3. Click the CONTACT HISTORY button.  

This will insert a new line at the top of the Contact History field (Name Comments/History tab) and 
stamps the current date and username at the beginning of the line. Simply add your comments then 
close the window. Every time you need to log another contact, just repeat the process. 

Additional Info 

The Names User Defined Fields are on the Additional Info tab. These are fields that your 
organization can use to collect data specific to your organization (e.g. name of individual’s spouse, 
hotel in which registrant is registered, etc.).  

EXERCISE: enter 12345 in the License # field and enter 01012000 in the Mem Since field.  

 Note: you can display UDF entries on the Main tab of the name record. To see this option, click the 
SAVE button to save your changes. When you save the record, you are moved back to the Main tab 
and you should now see the UDF data just under the Fee Category field: 

Adding Firm 
When entering the firm in a Name record, the default behavior is to save the Firm address and phone 
number (day phone) into the Name record.  

EXERCISE: create a Name record for yourself and enter your firm into the Firm field.  

1. Use one of the Add options (see page 18) to add a Name record. 

2. Enter your name, title and firm into the appropriate fields.  

3. Since there is no record for your firm in the system, when you tab out of the Firm field the 
system will bring up the Find firm window. Press the ESC key to close the window.  

4. The system will then ask if you want to create a firm record. Click the YES button. 

5. This opens the FIRM screen. Enter your address, zip code, and phone number (firm name will 
already be added for you).  
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6. Click the OK/CLOSE button on the FIRM screen. You’ll be returned to the Name record with 
the firm information entered into the appropriate fields.  

7. Continue entering your name data then click the SAVE button to save your record.  

Cloning/Pasting Records 
You can copy information from one record and paste it into a new one. This is useful when adding 
members of the same household or firm to the Names database.  

EXERCISE: create a record for Adam Miller's wife, Andrea, using the Clone/Paste Name routine.  

1. Open Adam Miller’s record. 

2. Select Edit > Copy Name to copy the information. 

3. Click the ADD button to create a new record. 

4. Select Edit > Paste Name to paste the information into the new record.  

5. Enter Andrea in the First name field.  

6. Click the SAVE button to save the new record. 

Name Grouping 
Group a series of Name records together and set one member as primary contact for the group (useful 
when you want you want to send catalogs to only one member of the group). Note: A name that is 
pasted from another record is automatically grouped with the record you pasted from. 

EXERCISE: group Tom and Debra Jones together and set Debra as the Primary member: 

1. Since the Name Grouping option is not enabled in the demo, we must enable it first. To do so, 
close the NAMES screen, then open the Preferences screen and select the Names tab. Now, check 
the Enable Name Grouping box (lower left of tab) then click the OK/CLOSE button to save your 
changes.  

2. Look up Tom’s record. 

3. Check the Grouping box to open the NAME GROUPING screen. Tom’s name is already added 
to the list. 

4. Click the ADD NAME button. 

5. Select Debra Jones. When you select her record, you’ll be returned to the NAME GROUPING 
screen and her name will be added to the list. 

6. Click on Debra’s name in the window. 

7. Click the SET AS PRIMARY button to set Debra as the primary contact.  

8. Click the OK button to close the screen and return to the Name record.  

This routine saves the primary contact's SSN/ID # in the Nmgroupid field on all name records in the 
group. There is a special report in the Mailing Labels area that only prints one label for the group's 
primary contact instead of printing one for each family member. We’ll take a look at that report in 
the Reporting Unit.  
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Name Quick Reports 
The Names QUICK REPORT button allows you to print fax cover, envelope, transcript, or letter for 
particular individual. 

EXERCISE: print a name quick report. 

1. Look up Adam Miller’s name record.  

2. Click the QUICK REPORTS button.  

3. Click the OK button to preview/print the report. 

Notes:  

● If your organization has the Email module, you can email the individual from Quick Reports. 

● If your organization has the Customer Relationship Management module, you can record a 
contact from Quick Reports. 

● If you always print the same Quick Report and just want to send it to the printer when you click 
the Quick Reports button, uncheck the Continue to display this screen box.  
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UNIT 4 

REGISTERING INDIVIDUALS IN COURSES 
 

 

Unit Objectives 

In this unit, you will learn to: 

● Add Registrations 

● Assess Fees 

● Make Payments 

● Print Receipts 

● Make Partial Payments 

● Create Billings 

● Void Payments 

● Cancel Registrations 

● Issue Refunds 

● Transfer Registrations 

● Transfer Payments 

● Group/Ungroup Registrations 
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Looking Up Registration Records 
Look up registrations in any of the following ways:  

✓ If you have the name record open, click the EDIT REGISTRATION button. 

✓ Click the Lookup Registration icon on the Quick Launch. 

✓ Click the Lookup Registration icon on the Student Manager Toolbar. 

✓ Select File > Find > Registration or Module > Registrations > Add/Edit Registrations (by 
Registrant) 

✓ Press Alt+G to highlight the Module > Registrations > Add/Edit Registrations (by 
Registrant) menu item, then pressing the Enter key to select the menu item. 

EXERCISE: look up Charles Havlicek’s name record and click the Edit Registration button to view 
his registrations. Then click the Find button and select the 24SACE010A registration.  

Registration Screen 

 

The REGISTRATION screen consists of 2 tabs:  

● Main Tab - Registration information is entered on this tab such as fee assessed and 
CEU/Hours/Credits/Grade earned. 

● Additional Info - Registration User Defined Fields are entered on this tab.  
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Registering an Individual 
The recommended method for registering individuals is through the NAMES screen. This allows 
you to verify and make any necessary changes to the individuals’ contact information before 
enrolling them.  

EXERCISE: register Adam in a course. To do so:  

1. Lookup Adam’s Name record.  

2. When the NAMES screen opens, click the ADD REGISTRATION button. 

3. Select the 24FPRGMNG course. 

The REGISTRATION screen now appears with the Registration information auto entered into the 
appropriate fields (i.e. ID and name, course info, main fee, total due, etc.). Adam received the Early 
Bird fee because he registered more than 30 days before the course begins. He was also assessed the 
mandatory Book fee (in the Additional Charges window).  

Assessing Additional Charges 

To manually assess Additional Charges: 

1. Click the ADDITIONAL CHARGES button.  

2. Select the appropriate fee (i.e. Calculator). The charge is added to the Additional Charges 
window and the Total Due is updated.  

3. Click the SAVE button to save the registration. 

Assessing Fee Adjustments 

You can also assess fee adjustments to a registration such as special charges (e.g. NSF fee) or 
discounts (e.g. coupon offering).  

EXERCISE: add a coupon discount to this registration.  

1. Click on the Fee Adjustment Description drop down and select Coupon Adjustment. 

2. Tab to the Amount field and enter -25.00. Note: if you are assessing a discount, you must enter 
the minus sign (-) as the first character of the amount, e.g. -25.00.  

 
3. When you type the last zero in the Amount field, the entry will automatically move into the 

Additional Charges window and the Total Due will be updated.  

Other Fee Options 

Charging Multiple Course Fees to a Registration - you can charge a registration multiple course fees 
by entering the number of fees to be charged in the Fee Number field (to the right of the X label):  
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When you tab out of the field, the Course Fee Amount will be multiplied by the Fee Number and 
the total will be entered in the Registration Fee Amount field:  

Assessing a Custom Course Fee - for organizations using the Allow Edit of Fee Amount on 
Registration preference: you can assess a custom fee amount. Enabling this preference allows users 
to enter the custom amount in the Course Fee Amount field (to the right of the @ label):  

 
When you tab out of the Course Fee Amount field, the Registration Fee Amount (and Total Due) 
will be updated. 

Making Payments 
To make a payment:  

1. Click the PAYMENTS button. This opens the PAYMENT screen with the total due 
automatically entered into the Payment Amount field.  

 
2. Select the Check Payment Type. The Payment Detail fields now appear (note: which fields are 

available depends upon the payment type selected).  

3. Enter the Check # 1234.  

4. Click the PRINT RECEIPT AND CLOSE button to open the RECEIPT PRINTING OPTIONS 
screen.  

5. Select Default Report then click the OK button.  
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6. The receipt will open for you to preview before printing. 

7. Close the RECEIPT PREVIEW window. 

8. To print the report, select YES on the SEND THIS REPORT TO THE PRINTER window.  

Once the report prints, the PAYMENT and REGISTRATION screens will close and you’ll be 
returned to the screen you opened the Registration screen from (i.e. Names, Course, Search).  

Note: you can also print a receipt from the Registration screen with the PRINT RECEIPT button. 
After printing the receipt, you are returned to the REGISTRATION screen.  

Making Partial Payments to a Registration 
You can make partial payments to a registration by entering the payment amount in the Payment 
Amount field before continuing the payment process (i.e. steps 2-8 above).  

EXERCISE: add Adam into another course and make a partial payment. 

1. Click the ADD REGISTRATION button.  

2. Select 24WPRGMNG from the Course list.  

3. Click NO on the Grouping Registrations window (we’ll talk about grouping later in this unit).  

4. Click the PAYMENTS button to make a payment.  

5. Enter 100.00 in the Payment Amount field.  

6. Select Cash from the Payment Type list.  

7. Click the SAVE button to save the payment.  

Important Note About Partial Payments 

When you click the PAYMENTS button you will NOT be placed in 'ADDING' mode because there 
is an existing payment record. Instead, you will be placed in 'EDITING' mode and will see the details 
of the payment you made earlier.  

You CANNOT start entering the payment details or you will be CHANGING an existing payment 
record. You MUST click the ADD button to open a new payment record. You can then enter the 
amount in the Payment Amount field and continue with the payment process.  

Creating Billings/Invoices 
You can also create ‘Billing’ payments for the purpose of invoicing a customer.  

EXERCISE: bill Adam for the remaining amount due for 24WPRGMNG. 

1. Click the PAYMENTS button.  

2. Click the ADD button to add a new payment.  

3. The remaining amount due is entered for you so you won’t need to edit the amount field.  

4. Select the Billing payment type. Note: by default, the bill will be directed to the person’s Firm 
(in Payment Details) if there is a firm entered on the Name record. If no firm is entered, it will 
be directed to the individual.  
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5. Enter 12345679 in the PO # field.  

6. Click the SAVE button to save the payment. 

When you click the SAVE button, the payment record is created but no Receipt Number is assigned. 
This is because billing records are not actually payments and should not receive Receipt numbers. 
If you have Company Invoicing, you assign an Invoice Number when printing new invoices.  

Payment Errors 
Occasionally, you may find that there is an error on a payment record that cannot be corrected (e.g. 
a payment was accidentally made but the individual did not pay, the payment amount is wrong, etc.). 
In these cases, you have two options: 

 Delete the payment - you may delete a payment--IF--it has not been assigned a receipt/invoice 
number yet (i.e. the Receipt Number field is blank).  

 Void the payment - if the payment has been assigned a receipt/invoice number, you must void 
the payment instead.  

EXERCISE: void a payment.  

1. Open Adam’s 24FPRGMNG registration record.  

2. Click the PAYMENTS button to open the PAYMENT screen.  

3. Select Void from the Payment Type drop down menu.  

4. Click YES on the CHANGE PAYMENT TYPE window.  

5. Click YES on the REMOVE CREDIT CARD NUMBER window.  

6. Enter a reason for voiding in the Reason for VOID field.  

7. Click the OK/CLOSE button to save your changes and close the screen.  

You should ALWAYS void payments if they have a receipt number assigned. This keeps the 
payment record so you can account for all receipt/invoice numbers with your auditors. 

Void Receipt/Invoice Tool 

Student Manager has a tool that allows you to void all payment records with the specified receipt or 
invoice number. This is an especially useful tool when you have more than one payment with the 
receipt/invoice number.  

Exercise: run the Void Receipt/Invoice tool. 

1. Select Tools > Financial >Void Receipt/Invoice.  

2. Enter C0000054 in the Receipt/Invoice # to Void field on the VOID RECEIPT/INVOICE screen.  

3. Click the PREVIEW button to see the payment records that will be voided.  

4. Press the Esc key to close the PREVIEW and return to the VOID RECEIPT/INVOICE screen. 

5. Click the CONTINUE button to void the payment records.  
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Canceling Single Registration 
How you cancel a single registration will depend on whether the registration has been paid or not. 

Registrations that have NOT been Paid 

To cancel a registration that has not been paid: 

1. Look up Charles Havlicek's 24FACE101A registration record.  

2. Check the Canceled box in the upper-right of the REGISTRATION screen.  

3. If the Quick Cancel Registration option is enabled on Registration Preferences, the system will 
clear out CEUS/HOURS/Credits and issue a fee adjustment to zero out the amount due.  

4. If the registration has billing records, you’ll be asked if you want to void them. Click YES to 
void the billing record, then add a reason for voiding the billing. 

Registrations that have been Paid 

If the registration is paid, use the Refund Wizard to cancel the registration and issue a refund: 

1. Look up Charles' 24FACE010A registration record.  

2. Click the PAYMENTS button to open the PAYMENTS screen. 

3. Click the REFUND WIZARD button to start the Refund Wizard.  

4. Select the following options:  

a. Refund to Payer.  
b. Total Amount Paid.  
c. Cancelation-Full Refund description. 

5. Click the PROCESS button.  

The registration is canceled, the CEUs/Hours/Credits are zeroed out, the fee adjustment is applied, 
and the Total Due is reset to 0.00.  

Refunding to Escrow 

You can also refund the fees to an Escrow account. Refunding to Escrow creates a new registration 
record called **Escrow** and transfers the money to it. The money is held in the Escrow account 
until you apply it to another registration.  

1. Look up Charles' 24FACE102A registration record. 

2. Complete steps 1-5 of the Refund Wizard process, selecting Refund to Escrow in step 4a. 

Applying the Credit to a Registration 

1. Use a look up registration option to pull up Charles’ registrations (green screen).  

2. Click the ADD button on the REGISTRATION screen. 

3. Select the 24FPRGMNG course from the course listing.  

4. When you’re returned to the PAYMENTS screen, click the PAYMENTS button.  
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5. Click the OK button on the CREDIT ON FILE window.  

6. On the PAYMENTS screen, click the ESCROW PAY button.  

Refunding Money without Canceling Registration 

You can refund money without canceling the registration (e.g. in the case of an overpayment).  

1. Look up Susan Kraft’s 23SACE010A registration record. 

2. Click the PAYMENTS button.  

3. Click the REFUND WIZARD button.  

4. Select the appropriate refund options: Refund to Payer and Amount Overpaid. 

5. Click the PROCESS button. The refund is processed but the course is not canceled. 

Cancel Course/Registrations Wizard 
The Cancel Course Wizard will cancel a course, all registrations, and issue refunds to the students.  

1. Select Module > Courses > Cancel Course. 

2. Select 24SACE010D from the course list. 

3. The system will ask you to confirm the cancellation. Select the YES – GET ON WITH IT button. 

4. Enter a reason for canceling (e.g. Low Enrollment). 

5. If you have the Pocket Ledger module, the system asks if you want to clear Faculty and Pocket 
Ledger entries for the course. Select the appropriate option.  

6. The MASS CANCEL/REFUND OF REGISTRATIONS window opens for you to select who to 
cancel/refund. Select the students who students who should be cancelled then click DONE.  

7. The CLASS LEVEL REFUND WIZARD screen opens. Select the appropriate options.  

8. If registrations have billings, you’ll be asked to void them. Select the appropriate option.  

9. You are now given the option to print a report. Select the appropriate report option.  

10. Click the OK button to close the window and finish the Course Cancel Wizard.  

Note: most of our payment gateways (i.e. Touchnet, Elavon) do not allow refunds through Student 
Manager. Currently PayPal is the only service that will allow you to refund through Student 
Manager. All others, you must process the refunds through the payment service site.  

Transferring Registrations 
You may transfer an individual to another class (registration)—or—transfer the registration (class) 
to another individual.  

1. Look up Susan Kraft’s 24SACE101A registration record. 

2. Click the TRANSFER button. 

3. The TRANSFER MODE window opens for you to select the appropriate option. 
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a. Click the CLASS button to transfer the student to another course. Select the course then 
follow the Transfer Wizard instructions below.  

b. Click the STUDENT button to transfer the registration to another individual. Select the 
individual to whom you want to transfer registration then follow the Transfer Wizard 
instructions below. 

For this exercise, click the CLASS button.  

4. Select 24UACE101A from the course list. 

5. The Transfer Wizard now opens.  

 
6. Verify transfer information and select the appropriate Fee Transfer option (Transfer all money 

to the new registration, Hold back a transfer charge, Leave all money with the old registration).  

7. Select the other options, i.e. Reset registration add date to today’s date, Keep copy of original 
registration, Bring along additional fees?, etc.  

8. A note is auto-entered about the transfer. You can edit or add to the note if desired. 

9. Click the PROCEED button. 

Transferring Payments 
You can transfer a single payment to another registration or to Escrow.  

1. Look up Susan Kraft's 23FFIN205A registration record. 

2. Click the PAYMENTS button to open the PAYMENTS screen. 

3. Click the TRANSFER PAYMENT (ESCROW) button to start the Transfer Payment Wizard.  
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4. The Payment Transfer window opens for you to select the appropriate option: 

Note: if transferring a partial payment amount, you must also enter the amount to be transferred. 

 
5. Select Transfer entire payment to another registration.  

6. Click the PROCESS button.  

Notes:  

● If you are transferring the payment to Escrow, the payment is transferred, the Payment screen 
is closed and you are returned to the REGISTRATION screen. 

● If you are transferring the payment to another registration, you must select the appropriate 
registration from the list. 

7. Select Sharon’s 24FFIN205A registration from the list**.  

The payment is now transferred. 

**You can only look up registrations by SSN/ID # or course number. If you are transferring to 
another person, you will want to look up that person’s SSN/ID # before you transfer the payment.  

Grouping Registrations 
The Grouping feature allows you to group any number of registrations together. You then make a 
single payment that the system automatically distributes among the registrations in the group. You 
can also print a single receipt that will show the payment detail for the grouped registrations.  

EXERCISE: group registrations together.  

1. Look up your name record. 

2. Click the ADD REGISTRATION button.  

3. Select the 24FPRGMNG course.  

4. When the REGISTRATION screen opens, click the SAVE button to save the registration.  

5. Click the ADD button (on the REGISTRATION screen).  

6. Select the 24WPRGMNG course.  

7. The system will ask you if you want to group the registrations. Click YES. 
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When you’re returned to the REGISTRATION screen, you’ll see the Group field is checked. You’ll 
also see new information in the Totals Box (Group Total Due, Paid, and Balance). 

Viewing Group Members 
You can view the members of your group by clicking the SHOW GROUP button. This allows you 
to verify that you have grouped the correct records together before making a payment. You can also 
navigate between grouped members’ registration records by highlighting the registration you want 
to view and pressing the ENTER key.  

Making a Payment to the Group 
You can now make one payment that will be distributed among the registrations in the group.  

1. Click the PAYMENTS button. The total due for the group will be auto-entered into the Payment 
Amount field. 

2. Enter the payment details (e.g. payment type, etc.). 

3. Click the OK/CLOSE button to save the payment and close the PAYMENTS screen. When you 
save the payment, the system creates a payment record for each member of the group and assigns 
the same receipt number to all the payment records.  

4. Click the PRINT RECEIPT button.  

5. Click OK on the RECEIPT PRINTING OPTIONS screen. The receipt shows registration and 
payment detail for all group members.  

Making Partial Payments to the Group 
You may also make a partial payment to grouped registrations. 

1. Look up Jason Allen’s 24UACE101A registration 

2. Click the PAYMENTS button.  

3. Enter 300.00 in the Payment Amount field.  

4. Select the Cash payment type.  

5. Click the SAVE button. 
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6. The system will ask you how you want to distribute the payment.  

 
● Proportional - applies percentage of payment to each registration (e.g. 40% of total due is 

assessed to one registration, so 40% of payment is applied to that registration).  

● Equally - applies an equal amount to each registration. 

● Specify - allows you to determine how much to apply to each registration. Enter the amount 
you want to apply to each registration in the To Pay field. Then click the APPLY button.  

 
7. Once you select your option, the system applies the partial payments to all registrations in the 

group.  

Grouping Existing Registrations 
You can group existing records together also (e.g. employees of a company register in courses that 
will be paid by the company with one check).  

1. Look up Lindsey Lieberman’s 24UACE101A registration record. 

2. Check the Group box.  

3. You’ll be asked if you want to link the registration with another group. Select YES.  

4. Find and select Cheryl Scott’s 24UACE101A registration.  

5. After you select the course, you’ll be returned to the REGISTRATION screen.  
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Ungrouping Registrations 
Sometimes you may need to remove a registration from a group. For example, ACEware 
recommends you ungroup a registration before issuing a refund or transferring a registration.  

1. Look up Lindsey Lieberman’s 24UACE101A registration record. 

2. When the REGISTRATION screen opens, uncheck the Group box. 

3. Select Remove this record from its current group.  

This removes the record from the group and the Group Totals information from the 
REGISTRATION screen. However, it does not alter any payments already made. If you made a 
payment before ungrouping, that payment will still exist with the originally assigned receipt number.  
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UNIT 5 

RUNNING REPORTS 
 

 

Unit Objectives 

In this unit, you will learn to: 

● Finding the Right Report 

● Run Main Reports 

● Run Queries 

● Print Reports 

● Set and Run Report Favorites 

● Run Special Reports 

● Reports without Queries 

● Statistical Reports 

● Output Reports in Other Formats 
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Student Manager provides over 200 predesigned report templates for you to view/print the 
information in your database.  

Module Quick Reports 
We’ve already seen some reports in the Quick Reports/Receipts areas: 

● Course Quick Reports button – print rosters, name tags, mailing labels, certificates, course 
description, or faculty contracts for particular course. 

● Names Quick Reports button– print fax cover, envelope, transcript, or letter for particular 
individual. 

● Registration/Payment Print Receipt button – print a receipt or letter of credit for particular 
individual. 

Quick reports give you data for the particular record you have open. For example, if you had the 
Master Course Record open to a specific course, the reports would display data for that course only.  

Student Manager Report Menu (Command Bar Item) 
Reports for a series of records (e.g. a series of courses) are run from the Reports menu. Reports are 
grouped according to the type of information contained in the report: 

● Accounting – Cashbox, Daily Income, Income/Enrollment Summary, Income Detail by 
Registrant, Special 1 Reg/1 Line (Deadbeat) 

● Demographics – Names data reports, Firm data reports, CRM reports, Mailing Labels 

● Courses – Courses Details, CEU Reporting, Income Summary, Room Use, Waitilists, Catalog 

● Registrations – Registrations with fees and payments, Optional Fee Counts, Receipts, Rosters, 
Transcripts, Name Tags, Certificates, and Tabletents 

● Faculty – Contract Agreements, Instructor Lists, Performance Data, Check Requests, Faculty 
Only Reports 

● Invoices – Invoices, Aging Reports 

● Pocket Ledger – Income/Expense Listings, Balances, Budgets 

● Workshops – Rosters, Enrollment Summary 

● Statistics – Names Demographic Sorting and Performance Summary, Tracking Codes, Course 
Data Summary and Performance Review, Tracking Codes 

● Codes – Student Manager Codes Listings 

Most of the reports in these areas require you to run a query—a request for specific data to be 
displayed on the report you select.  
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Finding the Right Report 
You must know the following information to find the right report: 

1. What type of report you want to run, i.e. do you want to print mailing labels or a course roster?  

2. What reporting area to access. Each report area contains specific information from the data 
tables, so you must know which area will give you the information you want. For example, to 
print course rosters you would choose the Reports > Registrations > Rosters reporting area. You 
would not choose a Faculty reporting area because registrant information is not available in the 
Faculty reporting areas. 

The Report Area Guide (Appendix B) tells you what information is available in the various 
reporting areas. In addition, a map of the Report Menu is in Appendix D.  

3. What records to include in the report. With most reports, you must run a query that tells the 
system which records to include in your report. For example, to print rosters for all courses 
beginning in the month of October, you would run a ‘Courses Beginning between 2 dates’ query 
and enter the date range. The system will search the data and return registrations for all courses 
beginning between the dates you entered.  

Once you know this information, you’re ready to run a report.  

Searching for Reports 

You can search for a report with the Search Report tool, which allows you to search reports by report 
title, field/variable name, function or character string.  

1. Select Tools > Reports > Search Report for Keyword.  

2. Enter your search string: 

 
3. Click the OK button.  

Student Manager will search all reports and give you a list of Master Reports and User Reports 
(separate lists) that contain the search string.  

 

EXERCISE: determine where to go to run a Name Roster report.  



 

42 

Running a Report 
Select the appropriate report area from the Reports menu. When you select the report area, the 
REPORT OPTIONS screen opens. Here’s a brief description of the available printing options. Note: 
listed options are not available in all report areas: 

● Preview to screen – see an on-screen preview of the report before sending it to the printer. 

● Export to file – export report data to an external file (i.e. Microsoft Excel, Text file, etc.). 

● Print New Invoices (Invoices > Run Invoices Only) –print invoices for all billing records which 
have not yet been assigned an invoice number (must have Company Invoicing module). 

● Print Marked Labels (Demographics > Mailing Labels Only) –all Name records which have the 
Print Label checked are included in your report. Note: you aren't given the opportunity to run a 
query if you select this option.  

● Set Start Label Position (Demographics > Mailing Labels, Registrations > Nametags) - allows 
you to print on a partially used label/name tag sheet. If checked, the system will ask you to 
specify on which label/name tag the system should start printing.  

● Exclude "Don't Mail" Names (Demographics > Mailing Labels Only) – if checked, will not 
include any Name record which has the Don't Mail box checked.  

● Record "CRM" Entry (Demographics > Mailing Labels and Registrations > Receipts) – if 
checked, after the report runs, you'll be given the opportunity to create a CRM entry for all Name 
records in the report (must have optional CRM Module).  

● Default/Specify Sort Order (Various Report Areas) – allows you to change the sort order for 
records included in report (e.g. change sort order of mailing labels from Zip+Last Name+First 
Name to State+Last Name+First Name).  

● Show Waitlisted Registrations – include waitlisted registrations in your report. 

● Include canceled records – include canceled records in your report. 

● Include Third Party Billing Reggies – include registrations marked as billing records. 

● Recycle Report Area – if checked, you’ll be returned to the REPORT OPTIONS screen after 
running the report. This is useful when you need to run a series of reports in the same area.  

● Recycle Query – if checked, you’ll be able to run reports in this report area with the same query. 
Once, again, this is useful when you need to run a series of reports in the same area and using 
the same criteria (e.g. courses between two dates). 

● Also Output As – export the report in various file formats.  

● Modify Report – check to modify the report.  

● Default/Additional Report – select the report you want to run. 

● Show User Reports – view the list of additional reports in this reporting area. 

● Use Windows Print Dialog – this option opens the standard Windows Print Dialog box when 
you print the report. You can then select the printer and printer options (i.e. number of copies, 
pages to print, etc.). If you don't select this option, the report will automatically be sent to the 
default printer when you print the report.  

Once you select your printing options, click the OK button to continue.  
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Query List Manager 
When you click OK on the PRINTING OPTIONS screen, the Query List Manager opens for you to 
run a query that selects the records you want to view on your report.  

 

Query List Manager Elements 

● Run Count - the Run Count indicates the number of times the query has been run. By default, 
queries are sorted by the Run Count so your most often used queries are always at the top.  

● Query Title – this is a descriptive title telling the user what the query does.  

● Query Buttons – buttons to run/manager queries. These buttons will be covered in Unit 6.  

 To run a query: 

1. Highlight the query you want to run.  

2. Click the SELECT button.  

3. Enter your search value. For instance, if you 
select the Courses offered between dates 
query, you must enter the date range for 
courses you want included.  

4. Click the OK button to continue.  

 

EXERCISE: select the Course offered between two dates query and enter 01/01/2024 in the From 
field, and 06/30/2024 in the To field. 
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Print Preview Window 
After the query runs, the Report PRINT PREVIEW window opens for you to view the report. Note: 
the PRINT PREVIEW window opens ONLY if you selected the Preview to screen option in the 
report’s Printing Options. 

 

Use the Print Preview Toolbar to view pages of the report, zoom in or out, print the report or close 
the Report Preview Window.  

 

 

 

  

First Page Go to Page Last Page Pages per View (1, 2 or 4) Print 

Previous Page Next Page Zoom Close Print Preview  
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Report Favorites 
Student Manager users can identify up to 10 reports as Favorites so they can be easily found and 
run.  
 
EXERCISE: run a favorite report. 

1. Select Reports > Favorites or use the keyboard shortcut Ctrl+F1.  

2. Click the RUN REPORT button next to the Mailing Labels – Default option.  

3. Select the report options: Preview to Screen, Exclude "Don't Mail: names.  

4. Click the OK button.  

5. Enter 24SACE010A into the Course Number begins with query box.  

6. Click the OK button.  

The mailing label report now runs. 

 
EXERCISE: add a favorite report.  

1. Select Reports > Favorites or use the keyboard shortcut Ctrl+F1. 

2. For favorite # 6, click the SET REPORT button.  

3. Select Registrations from the Area drop down list.  

4. Select Certificates from the Sub Area drop down list.  

5. Select Default from the Report Name drop down list.  

6. Select Courses End Date between two dates from the Query drop down list.  

7. Click the DONE button.  

8. Click the SAVE button on the FAVORITE REPORTS window.  

The report is saved to your Favorites list and can now be run.  

Global Favorites  

The Student Manager Administrator can also identify global report favorites that can be run by all 
users.  

To run a global report favorite: 

1. Select Reports > Global Favorites. 

2. Click the RUN REPORT button next to the Name Roster option.  

3. Click the OK button on the REPORT OPTIONS window.  

4. Enter 24SACE010A into the Course Number begins with query box.  

5. Click the OK button.  

The Name Roster report now runs.  
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Special Reports 
There are several special-use reports that can be run from the main Student Manager screen: 

● F2 Quick Counts – view or print enrollment counts for upcoming courses.  

● Ctrl+F2 Quick Room Use - see what classes are meeting today.  

● F3 Instructor Talent Search –search for instructors based on various criteria.  

● F5 Person Locator - search for Name records based on various criteria.  

● F7 Pay Grabber - search for Payment records based on various criteria.  

● F9 Dashboard - gives you a quick look at courses with low enrollment, courses full or nearly 
full, summary of enrollments and income (for the day, week, quarter, year), and counts of web 
enrollments.  

● Membership – for customers who have Membership programs. The Membership Retention 
Wizard returns student retention status, courses taken, or a list of students meeting specified 
membership criteria.  

● Financial Aid – available with the Financial Aid module that allows you to track Financial Aid 
disbursements. The Financial Aid report returns information about student awards/draws. 

Reports without Queries 
Some reports don’t require you to select a query. For example, the Marked Label report. If you've 
checked the Label Flag on selected Name records, all you need to do is check the Print Marked 
Labels box on the Mailing Labels REPORT OPTIONS screen to run a report for the records. 

EXERCISE: run the Marked Labels report.  

1. Select Reports > Demographics > Mailing Labels. 

2. Check the Print Marked Labels box on the PRINTING OPTIONS screen. 

3. The system will now search for all records that have the Label box checked and include them in 
the report: 

 
Note: the entry you entered in the Label Info field (i.e. 
Brochure) is displayed on the label as well so you know 
what to send the individual.  
 

4. Close the PRINT PREVIEW window. 

5. Click NO on the SEND TO PRINTER window.  

6. The system will ask you if you want to clear the Label flag (i.e. uncheck the box on the Name 
records). Click the YES button. 

7. Look up Adam’s record and verify that the Label Flag box is now un-checked. 

Other reports that don’t access the regular Query List Manager are Cashbox, Print New Invoices, 
and Snap Shot.  
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Statistical Reports 
Student Manager also offers various statistical report options:  

Reports > Statistics > Course 

● COURSE DATA SUMMARY - course statistics based on various criteria. E.g. a Department 
Summary report with how many courses per department, enrollment, income and expenses.  

 

●  COURSE PERFORMANCE REVIEW - look at course performance based on income, 
enrollment, or CEUs or hours generated.  

Reports > Statistics > Names 

● DEMOGRAPHIC SUMMARY - demographic statistics based on various criteria. E.g. look at 
the semester's breakdown of registrants by city.  

 

● NAMES PERFORMANCE SORTING - find out individuals who were your biggest spenders, 
earned the most CEUs or hours, or took the most courses for a given period.  
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Reports > Statistics > Tracking Codes 

● TRACKING CODE REPORT - determine the success of your various advertising campaigns.  

 

 

Output Reports in Other Formats 
You can also save your report in various formats. To do so: 

1. Select the appropriate Report area (e.g. Reports > Registrations > Rosters > Name Rosters).  

2. On the PRINTING OPTIONS screen, select the desired output format from the Output As drop-
down: 

 
3. Enter the path (location for the saved file)* and name for the file. You can enter it directly into 

the path field, or you may click the Ellipsis button to the right of the Path field and select the 
location and enter the file name.  

*We STRONGLY discourage saving files into your Student Manager directory. Instead, create 
a folder on your C:\ drive called ACEHOLD and save the Output files to this location.  

4. Select any other appropriate printing options (e.g. Include Canceled Records, Additional Report, 
etc.), then click the OK button.  

5. Select and run the appropriate query. If you selected Additional Report, select the appropriate 
report after running the query.  

6. The file will now be created.  
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UNIT 6 

MANAGING QUERIES 
 

 

Unit Objectives 

In this unit, you will learn to: 

● Search for Queries 

● Sort Queries 

● Use Character Type Query Options 

● Add Queries 

● Edit Queries 

● Rename Queries 

● Copy Queries 

● Delete Queries 
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Searching for Queries 
At times, you may need to query by a certain field but you don’t know what reporting areas will 
allow you to query by that field. To find out, you can search queries for the specific field. To do so: 

1. Select Tools > Reports > Search Queries for field.  

2. Enter the field name*. 

 
3. Click the OK button. The system will return a list of all reporting areas in which the specified 

field is available.  

*If you don’t know the field name, you can look it up in Online Help.  

https://www.aceware.com/smhelp/Content/ScreenLayout.htm  

Sorting Queries 
By default, queries are sorted by the Run Count. To sort queries by Query Title, click on the Query 
Title Column Header (the gray bar named Query Title).  

 
This will sort your queries in A-Z order. Other Sort options include:  

● To sort queries in Z-A order, click the Query Title Column Header twice (i.e. the first time will 
sort them in A-Z order. The second time will sort them in Z-A order).  

● To sort queries by Run Count, click the Run Count Column Header. 
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Character Type Queries 
Queries that have Character type elements (e.g. Course Number begins, Subject Code is, etc.) offer 
users the ability to select a query item from the list of available field values. For instance, a Course 
Number Begins query allows you to select the course number from a list of all course records in 
your system.  

The query item is selected by clicking the Ellipsis button (button with 3 dots [...]) to the right of the 
Query field. This opens the list of available values for the query element. Double-click a value in 
the list to select it and add it to the Query field.  

Creating Queries 
The most common queries are already created in Student Manager reporting areas. However, most 
organizations will need to create or modify queries to meet their specific needs. Here are some 
general rules to follow when creating queries: 

● The field you want to use in your query must be available in the reporting area. 

● You may create an unlimited amount of queries in each reporting area. Although, it is best to 
only maintain those queries that you most commonly use. 

● Queries can only be used in the particular reporting area in which they were created. 

● Unless you check the Include Cancelled Records box on the PRINTING OPTIONS screen, 
cancelled records will not be included in your report—no matter what you add to the query.  

To create a new query:  

1. Click the ADD button on the Query List Manager.  

2. Enter a title for your new query (i.e. a descriptive name such as 'Courses between two dates'). 

3. After you enter the title, the QUERY window will open for you to add query elements.  

4. Click the ADD button to add a query element.  

5. On Step 1: Select a field, select the field from the list (e.g. for course number is between two 
dates, select Course Begin Date).  

6. On Step 2: Pick Operator, select the comparison you want to make on the field (e.g. for courses 
between two dates, you would pick 'Between two dates').  

7. On Step 3, enter Lower & Upper Dates. Most of the time you should select ASK LATER. This 
keeps the query as generic as possible so that it can be applied in a variety of ways.  

Adding Additional Elements 

Sometimes you want to add additional elements to the query. For example, you want to query on 
course dates and course number. You do this by simply pressing the ADD button again and selecting 
the connector you want between the two elements:  

● AND means that BOTH items must be true for a record to be included in the result.  

● OR means that if ‘EITHER ONE’ of the items is true it will be included.  

After choosing the connector, repeat steps 5-7 (above). 
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Multiple Element Queries 

You may occasionally need to create a query with a combination of elements. For example, you 
need courses between two dates except for courses which have "MGT" in the course code and are 
offered by a specific department.  

Note: with multiple element queries, you must keep in mind is whether you want one, some, or all 
the conditions to be true:  

● All conditions must be true - make certain you use the AND connector. This means that if any 
single condition is not met, the record is not included (e.g. the course must begin between the 
two dates, AND not include "MGT" in the course code, AND have a specific coordinator).  

● One of the conditions must be true - use the OR connector. This means that if the record meets 
one of the conditions, it will be included (e.g. the course must begin between two dates, OR 
must not contain "MGT" in the course code, OR must have a specific coordinator).  

● Combination of conditions must be true - you may need to use a combination of connectors 
along with the bracketing feature (see below) to govern how the query is analyzed. 

Switching Element Connectors 
If you used the wrong connector with a query element (e.g. OR instead of AND), you can switch 
the connector by clicking the SWITCH button, then clicking the element you want to change. 

Moving Query Elements 
You can also change the order of elements with the MOVE button. For instance, you added the 
element 'Course Number begins with or matches' as the third element but you realize it needs to be 
first. To move a query element: 

1. Click the MOVE button. 

2. Click the query element you want to move (e.g. Course Number begins with or matches). 

3. Click where you want to move the query element (e.g. if you want it to be the first in the list, 
click the first query element) 

The element moves to your chosen position--the other query elements will be shifted down. 

Bracketing 
Some queries cannot be reliably used unless elements are bracketed to determine the order of 
execution of the elements. Conditions inside the brackets will always be evaluated before any 
conditions outside of the brackets.  

To insert brackets: 

1. Click the BRACKET button. 

2. Click the INSERT button. 

3. Click the first condition you want included inside the brackets. 

4. Click the second condition you want to include inside the brackets. 

The selected elements will now be surrounded with parenthesis (). 
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Copying Queries 
To copy an existing query, highlight it then click the COPY button. Give the copy a new name then 
click OK. 

Editing Queries 
To edit an existing query: 

1. Highlight the query you want to edit.  

2. Click the EDIT button.  

3. The QUERY screen opens for you to make changes to the query elements.  

4. To edit a query element, click the EDIT button on the QUERY screen.  

5. Click the element you want to edit. Note: if there is only one element in your query, the system 
will skip this step and take you to step 6. 

6. The QUERY EDITING INSTRUCTIONS window opens. After reading the instructions, click 
OK to close the window. 

7. When editing query elements, the system starts with Step 3 of the Adding Query Element routine 
and works backwards through the steps.  

● If you need to edit Step 3: Enter Value only - make the necessary change and click the OK 
button. This will return you to the QUERY screen 

● If you need to edit Step 2: Pick Operator - click the CANCEL button. This returns you to Step 
2. If the change you need to make is on Step 2 (i.e. change from 'Begins with' to 'Exactly 
Matches') you can make it now. The system will then move you forward to Step 3.  

● If you need to edit Step 1: Select a Field - click the CANCEL button on Step 3 then click 'Step 
Back' on Step 2. This will return you to step 1 where you can select a different field. Since 
you selected a new field, you must complete Steps 2 (pick the operator) and 3 (enter a 
comparison value) again.  

8. After completing the steps, you'll be returned to the QUERY screen. Click the OK button to save 
your query changes.  

9. You'll be returned to the QUERY LIST MANAGER window.  

Renaming Queries 
Query Names should be as descriptive as possible so that all users know what information the query 
will request from the data tables. If you edit a query, then you may need to rename it. To rename a 
query:  

1. Highlight the query. 

2. Click the RENAME button.  

3. Make the appropriate changes to the name.  

4. Click the OK button to save the new name and return to the QUERY LIST MANAGER window. 
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Deleting Queries 
Part of your query management is to periodically delete old or unused queries. To delete a query:  

1. Highlight the query you want to delete. 

2. Click the DELETE button. 

3. Confirm the delete procedure by clicking YES on the Confirmation dialog box. 

4. The query is removed from the QUERY LIST MANAGER window. 
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UNIT 7 

INTRODUCTION TO THE REPORT DESIGNER 
 

 

Unit Objectives 

In this unit, you will learn to: 

● Open the Report Designer 

● Add report elements 

● Set element format (color, font, etc.) 

● Move report elements 

● Align report elements 

● Delete report elements 

● Change Page Setup 

● Save reports 
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Report Designer 
The report templates included with Student Manager may or may not fulfill your organization’s 
needs. That's why Student Manager also provides you with a full-featured report designer. With it, 
you can modify any existing report to fit your needs. 

To modify a report: 

1. Select your report (e.g. Reports > Registrations > Rosters > Name Rosters).  

2. On the report's PRINTING OPTIONS screen, check the Modify Report box.  

3. Select and run your query. 

4. The REPORT DESIGNER now opens.  

 

The report template consists of white spaces separated by gray horizontal bars called bands. The 
white space above each band contains the report elements that will display on the report (e.g. text 
entries, expressions, lines, etc.).  

Before we begin discussing the report template, preview the report by selecting File > Print Preview 
(or use the shortcut Ctrl+I). 

When you return to the report template, you'll begin to see the relationship between the gibberish 
on the template and the finished product. For instance, notice that the Namer(rgid,3) field box is 
located in the same area on the report template as the individual’s name on the report preview. 



 

57 

Report Modification Tools 
Student Manager's report designer provides you with several tools to help simplify your report 
modification.  

Report Designer Toolbar 

With the Report Designer Toolbar you can display dialog boxes and open report control toolbars.  

Tools Menu 

Tools can also be accessed with the Report Designer Menu options: 

● File – Close Report, Page Setup; and Print Preview. 
● Edit – Cut, Copy, Paste, Select All, etc. 
● Format - Alignment and Sizing options; Element Grouping and Order, Formatting options for 

text, lines, and boxes (e.g. color, font, line size, fill color and type). 
● Report - Banding; Variables, Data Grouping; Set Default Font for Report. 
● Window – Lists current report window. 
● Help – Access Report Help. 

Report Controls Toolbar 

Use the Report Control Toolbar icons to add and modify report elements: 

 

Data Grouping 

Data Environment 

Reports Control 

Color Palette 

Layout 

Page Setup 

Font Properties 

 

 With the Select tool, you select report elements to modify or move.  

 The Label tool is used to create text entries up to 256 characters in length. 

 The Field tool is used to draw expression boxes in which to place data.  

 Draw vertical and horizontal lines with the Line Tool 

 Draw rectangular boxes on your report with the Rectangle tool.  

 Draw round-edged boxes with the Round Rectangle tool.  

 Draw a box for a picture with the Picture tool. 

 The Button Lock will keep the current tool selected for multiple additions. 
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Adding Text Elements 

To add a text entry to your report: 

1. Click the Label tool on the Report Controls Toolbar. 

2. Click where you want to place the text. You'll see a blinking cursor where you clicked. 

3. Begin typing your text. 

4. Click out of the text box when you’re finished.  

Note: Each text box can hold 256 characters--that includes spaces, punctuation and hard returns.  

Adding Lines 

To add a line to your report: 

1. Click the Line Tool on the Report Controls Toolbar. 

2. Click and drag the line--either vertically or horizontally--to the length you want.  

3. Release the mouse button to stop drawing the line. 

Adding Boxes 

To add a box to your report:  

1. Click on the Rectangle tool or the Rounded Rectangle tool. 

2. Click where you want to place the rectangle and draw a box. 

3. Release the mouse button to stop drawing the box.  

Adding Pictures 

To use a picture in a report, such as your organization's logo, you must place it within the Student 
Manager folder first. Then follow these steps to link to the picture:  

1. Click on the Picture tool on Report Controls Toolbar.  

2. Click where you want to place the graphic and draw a box. 

3. When you release the mouse button, the REPORT PICTURE window opens. 

4. Click the Ellipsis button to the right of the File field to select the picture file.  

5. Select the picture then click OK. This will return you to the REPORT PICTURE window.  

6. You must now determine the picture sizing option: 

● Clip Picture – If the picture is bigger than the box you created, shows a section of the picture. 
You cannot see the portion of the picture that extends beyond the box. 

● Scale picture, retain shape (Recommended) - Displays the whole picture retaining the relative 
proportions of the picture. This will protect your picture from vertical or horizontal distortion.  

● Scale picture, fill the frame - Display the whole picture, filling the box completely. If necessary, 
the picture will be distorted vertically or horizontally to fit the box. 

7. Click the OK button to close the Report Picture box and return to the REPORT DESIGNER. 
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Adding Fields 

There are two ways to add fields to your report:  

Adding Fields from the Data Environment List** 
When your run a report, the system creates a temporary file called a 'cursor' in which it places data 
from the records that match your query. To add one of the fields from the cursor to your report: 

1. Click the Data Environment icon on the Report Designer Toolbar. 

2. Scroll through the list of available fields to the field you want to include in your report.  

3. 'Pick up' the field (with the mouse) and drag it to the report.  

Adding Fields with an Expression Box** 
You can also add fields to your report by creating an expression box and entering the field name 
into the Expression field. To create an expression box:  

1. Click the Field tool on the Report Controls Toolbar. 

2. Click where you want to place the expression and draw a box.  

3. When you release the mouse button, the REPORT EXPRESSION window 
will open. 

4. Type the field name into the Expression field.  

5. Click the OK button to close the REPORT EXPRESSION window. 

**If the field does not exist in the report cursor, you will receive an error message when you preview 
the report. In these cases, you must use a report function to add the field to your report if it is not in 
the report cursor (see Unit 8 for more information about report functions). 

Changing Report Element Colors 

You can change the color of reports elements. To change the color of an element: 

1. Click the Color Palette icon on the Report Designer Toolbar to open the Color Palette.  

2. Highlight the appropriate report element. 

3. Click the appropriate icon on the Color Palette to set foreground/background color: 

 
Background Color – set the background color of an element. Use this tool to set the 
fill color of boxes. Note: this is the default option when you open the Color Palette 
(will be ‘pressed’ down). If you don’t want to set the background color of an element, 
you must click it to de-select it (so it’s not ‘pressed’ down).  

 
Foreground Color – set the foreground color of an element. Use this tool to set the 
font color, line color and border color of boxes.  

If you don’t see the color you want on the Palette, click the OTHER COLORS button to open the 
CUSTOM COLORS window.  
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Changing the Font of Report Elements 

To change the font of a report element, highlight the element then select FORMAT > FONT and 
make the appropriate changes.  

Note: you can set the default font for all NEW elements added to the report from REPORT > 

DEFAULT FONT. 

Setting Line Style 

To set the line style: 

1. Highlight the line. 

2. Select FORMAT > PEN. 

3. Select the appropriate option. 

Setting Fill Type 

To set the fill type of a box: 

1. Highlight the box 

2. Select FORMAT > FILL.  

3. Select the appropriate fill type. 

Note: when you set a fill color/type, you may need to send the box behind other elements or they 
won’t be visible. To do so, click on the box then select FORMAT > SEND TO BACK.  

Formatting Fields 

You may need to apply special formatting to some fields so that they display properly. For instance, 
you may want a dollar sign in front of money, a SSN or a phone number formatted properly. To 
apply formatting to a field:  

1. Double-click the field to open the REPORT EXPRESSION window 

2. Click into the Format field and type the appropriate format*. 

In the following formatting examples, 9s are entered as place holders, telling the system how many 
digits/characters to display. Note: you will also need to enter the @ sign and appropriate symbol ($ 
or R): 

 Currency - @$ 999,999.99 (displays 6 digits of the amount and 2 digits of the cents with a 
comma at the thousand mark). 

 Phone Number - @R (999) 999-9999 (places area code in parentheses and a dash between 
the exchange and number) 

 SSN - @R 999-99-9999 (places dashes in number) 

*You may also set the formatting on the Format window. To open it, click the Ellipsis […] button 
to the right of the Format field. This window gives you formatting options for each field type (i.e. 
Character, Number, and Date). Select the appropriate option to see formatting options for the 
specific field type.  
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Stretch with Overflow 

You have the option to let the contents of a field wrap to the next line if the expression box is not 
wide enough to display the entire field contents (e.g. a course title is longer than the box). To do so: 

1. Double-click the field to open the REPORT EXPRESSION window.  

2. Check the Stretch with overflow box. 

3. Click the OK button to close the window.  

Field Position 

If you are using the ‘Stretch with overflow’ option (above) on a field, you may need to set the 
position of fields below it with the Field Position option. For example, if you set the course title to 
wrap to the next line but you have another field placed directly under it, the course title will print 
over the other field’s contents if it wraps.  

 
To keep this from occurring, you must set any fields underneath your stretched field to “Float”. 
Floated elements move down according to length of field information above it.  

Moving Report Elements 

If you don't like where the report elements are presently located, you can move them. To move one 
item, pick up the element and drag it to where you want it. Or click on it to highlight it then use one 
of the Arrow keys to move it.  

Selecting Multiple Elements 

If you want to move more than one element at a time, highlight the elements in one of the following 
ways: 

● Click on the first element. Hold down the Shift key while clicking on the other elements you 
want to move.  

● With your mouse, draw a box around the elements you want to move.  

Once they're highlighted, you can pick up and drag them to where you want them. Or use the Arrow 
keys to move them.  

The cobegdate,’-‘,coenddate field is 
right under the rgcrse,cocrsenm field. 
 
The wrapped Course Title prints over 
course dates. 

Cobegdate,’-‘,coenddate field is set to float. This 
allows the information to move down if the course 
title is wrapped to the next line. 
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Resizing Report Elements 

If you want to resize a report element (e.g. resize a field so it’s wide enough to display the contents 
or resize a box), highlight it so you can access the adjustment handles, then grab the appropriate 
handle and drag it to expand or retract the element. Or, hold the Shift key down and use the 
appropriate Arrow key to resize the element.  

Aligning Report Elements 

After you have moved your elements, you may need to re-align them. To align elements: 

1. Highlight the elements you want to align. 

2. Click the Layout icon on the Report Designer Toolbar to open the Layout Toolbar.  

Controls on the Layout Toolbar allow you to left, right, top, bottom, vertically or horizontally align 
elements. You can also vertically or horizontally center them, make them all the same height or 
width, and send them behind or in front of other elements.  

Deleting Report Elements 

If you want to remove an element from the template, just click on it then press the Delete key.  

Page Setup 

To add/edit columns within the report or change the page orientation (portrait vs landscape), select 
File > Page Setup. From here, you: 

● Set the number of, width, and amount of space between columns 

● Set the left margin 

● Determine the print area 

● Determine print order (if using columns) 

To change the orientation of the page, click on the PRINT SETUP button. This will open the 
standard WINDOWS PRINTING DIALOGUE window where you can change the orientation, paper 
size, and default printer for the report. 

Saving Changes 

Once you have made all the report modifications, you're ready to save your changes: 

1. Select File > Close, OR--Use the shortcut key: Ctrl + F4. 

2. Click YES on the SAVE CHANGES window. 

3. The SAVING MODIFICATIONS window will open next. If you modified a pre-defined report, 
you have these options. 

a. Saving your changed report as the pre-defined report: click the SAVE AS DEFAULT 
button. Next, you'll be given the option to replace the original pre-defined report or save the 
old report first. Select your desired option.  

b. Creating an additional report: enter a title in the Report Title field, then click DONE. 
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If you modified an additional report, the report will already be titled. You can:  

a. Save the changes to the report by clicking the DONE button.  

b. Create a new additional report. To do so, re-title the report, then click DONE. 

TIP: when modifying or creating reports, write a short description about the changes in the Report 
Notes field. Writing notes reminds you what a report does (and lets others know too). 
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UNIT 8 

ADVANCED REPORT WRITING 
 

 

Unit Objectives 

In this unit, you will learn to: 

● Use report functions 

● Write complex report expressions 

● Add/Edit group bands 

● Add print whens 

● Create variables 

● Use JustDoIts and JustAfters 
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Adding Functions to Reports 
Functions are mini-programs that can access information not available in the report cursor, format 
information in a specific manner, or perform calculations on report data.  

A function consists of a name followed by a set of parenthesis. Within the parenthesis, you enter 
parameters—these are pieces of data that the function needs to process/return information. Some 
functions require one parameter only, others require several. If you must enter more than one 
parameter, you separate them with a comma (,).  

Take a look at these three simple functions to see examples of how a function should be written. 

● ADDCRSE - returns a field from the Course table. You must pass it the course code field that 
is available in the report cursor (see Parameters: SSN/ID and Course Code below), and the name 
of the field you want to return in quotes.  

Example: ADDCRSE(cocrse,"codept”) returns the course department.  

 
● NICEDATE – returns the date in text format. You must pass it the date field. You can also pass 

it a second date and it will give you the date range in text format.  

Example: NICEDATE(cobegdate,coenddate) returns course range of dates, e.g. December 1-5, 
2024. 

 
● GTDUE – returns total amount due for a registration. You must pass it the course code field and 

the name ID field. 

Example: GTDUE(rgcrse,rgid) returns the total amount due for an individual in a specific 
course, e.g. 250.00.  

 
Since this is a money field, we’ve also formatted it to display in currency format.  
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Parameters: SSN/ID and Course Code 

Many functions require the individual’s SSN/ID and/or the course code. These fields exist in several 
databases and are named according to their respective database. For instance, the SSN/ID in the 
Names database is named NMID, in the Registration database it is named RGID. The course code 
is COCRSE in the Course database, RGCRSE in the Registration database.  

The report area determines which of the SSN/ID and course code fields are available in the cursor. 
For example, COCRSE is the available course code field in the Reports > Courses report area. But 
in the Reports > Registrations report area, RGCRSE is the available course code field.  

In your functions, you may use whichever field is available in the report cursor. To see the list of 
available fields in your report cursor, click the Data Environment icon on the Report Designer 
Toolbar. Then you can scroll down the list of available fields to see which one is available.  

Report Function Help 

The Online Reference Guide lists all report functions available in Student Manager, their uses, 
required and optional parameters, and examples of function expressions. Access the Online 
Reference Guide at: aceware.com/smhelp/  

To search for functions, select Reporting Functions from the Filter list.  

Complex Expressions 

Sometimes you will need to use more complex expressions to achieve the desired results. For 
instance, you may need to add a field to your report and format it. This can be accomplished in one 
report expression by combining functions.  

Here are some examples of complex expressions:  

● One function nested in another: 

NICEDATE(cobegdate,ADDCRSE(cocrse,”coenddate”)) 

Adds coenddate to report then formats the course dates in text format.  

● Several functions nested together in an IIF statement:  

IIF(EMPTY(nmname3),ADDNAME(rgid,"nmfirm"),NAMER(nmid,2)) 

If the registrant's last name field is empty, then add the firm name to the report and display it, 
otherwise display the registrant’s name formatted with the NAMER function. 

● Combining text elements and fields to create a paragraph in a confirmation letter: 

"The total cost for this course is $"+LTRIM(STR(due,8,2))+". We show that to date you 
have paid a total of $"+LTRIM(STR(paid,8,2))+". This leaves you a balance due of 
$"+LTRIM(STR(due-paid,8,2)) 

Uses the STR function to convert the number fields due and paid to Text, and the LTRIM 
function to trim extra spaces from the left of the number fields. Then the text and fields are 
combined using the plus sign concantenator to form the paragraph. 
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Complex Expression Rules 

When writing complex expressions, remember these rules: 

1.  Your expression cannot be longer than 256 characters (maximum number of characters the 
Expression field can hold). Don't forget that spaces, punctuation, etc. are counted as characters 
too and are therefore included in the maximum count (e.g. "The total cost for this course is:" = 
38 characters even though the expression only contains 27 letters). 

2. Every function MUST have an opening and a closing parenthesis.  

 
3.  Text elements must be enclosed in quotations (“”) in report expressions. 

 
4. Fields in your expression must be the same type, or they must be converted to the same type 

using a report function such as Transform (i.e. number to character). 

 
5. Combine elements in an expression using one of the following concatenators:  

a. Comma (,) - places a space between fields. 
 
Returns: 

Chuck Havlicek 

b. Semi-colon (;) - places a carriage return between fields. 

Returns: 

President 
ACEware Systems, Inc.  

c. Plus sign (+) - places nothing between elements.  

Returns: 

Manhattan, KS 
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Comparison Operators 

The following Comparison Operators can be used in complex report expressions: 

Numeric Comparison Operators 
● = - Equal to specified expression (e.g. rgcrsefee=125.00 returns a registration if the 

registration fee is equal to 125.00). 

● => - Equal to or Greater than specified expression (e.g. rgcrsefee => 125.00 returns a 
registration if the registration fee is greater than or equal to 125.00). 

● <= - Lesser than or Equal to specified expression (e.g. rgcrsefee <= 125.00 returns a 
registration if the registration fee is lesser than or equal to 125.00). 

● <> - Not equal to specified expression (e.g. rgcrsefee <> 125.00 returns a registration if the 
registration fee is not equal to 125.00). 

Arithmetic Operators 
● + - Addition 

● - - Subtraction 

● * - Multiplication 

● / - Division 

Character Comparison Operators 
Note: character strings must be enclosed in quotation marks. 

● = - Equal to specified expression (e.g. pytype='3' returns a payment if the payment type is 3 
[Billing]). 

● $ - Specified expression is contained in another expression: 

pytype $ '12456' returns a payment if the payment type is 1 [Cash], 2 [Check], 4 [Visa], 5 
[Master Card], or 6 [Discover] 

'aceware.com' $ nmemail returns a name record if it has aceware.com in the email address 

● <> - Not equal to specified expression (e.g. pytype <> '8' return a payment if the payment 
type is not 8 [Void]). 

Logical Comparison Operators 
● ! - Not equal to the specified expression (e.g. !rgcancel returns a registration if it is not 

canceled). 

Note: this operator can also be used with certain report functions. For instance, the Empty() 
function returns a value if the specified field is empty. !Empty() will return a value if the 
specified field is not empty.  

 

 

 



 

70 

Report Banding 
The function of report bands is to give structure to the display of the report data. Some bands on a 
report template differentiate areas of the page layout (e.g. Title, Page Header). Other bands group 
records together in a hierarchical form. The following lists types of bands and their uses:  

● Title - information that appears at the beginning of the report (e.g. title, introduction, cover page) 

● Page Header - information that is printed at the top of each page in the report (e.g. date, report 
title, logo) 

● Group Header - information that is printed at the beginning of each data group (e.g. course 
number and title, individual's name and address) 

● Detail - information printed once for each record generated by the query (e.g. individuals 
registered in class, all individual's optional fees) 

● Group Footer - information printed at the end of each data group (e.g. total enrolled in course, 
total amount due for each individual) 

● Page Footer - information printed at the bottom of each page in the report (e.g. special notes or 
instructions, signature lines) 

● Summary - information printed at the end of the report (e.g. summaries, conclusions, final totals) 

Adding Group Bands 

To add a Group Band to a report: 

1. Click the Data Grouping icon on the Report Designer toolbar to open the Data Grouping 
window. 

2. Click into the Group box and enter the field/expression on which to group (e.g. rgcrse, nmid, 
substr(nmzip,1,5) etc.). 

3. Select the appropriate Group properties (e.g. start each group on a new page, reprint group 
header on each page, etc.). 

4. Click the OK button to save the Group band and close the Data Grouping window. The group 
header and footer will be added to the report template. 

Adding Title/Summary Bands 

The Title and Summary Bands are optional bands that can be added to your report. To add the 
Title/Summary bands: 

1. Select Report > Title/Summary. 

2. Check the band you want to add to the report.  

3. Select the paging option (i.e. if you want the title or summary band information to be displayed 
on its own page, select 'New Page'). 
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Expanding/Contracting Bands 

Bands can be resized. To adjust the amount of space in the band:  

1. 'Pick up' the band with your mouse and drag it where you want it. OR-- 

2. Double-click the blue arrow on the band to open the band's properties window. Set the size you 
want the band to be in the 'Height' field.  

Print Whens 
You may determine when a field prints by setting a Print When. To do so, open the field’s Report 
Expression window then click the Print When button. 

● Print Repeated Values – ‘Yes’ allows the value to print repeatedly; ‘No’ prints the value only 
once per group. 

● Also Print - 99.9% of the time you will leave these as they are.  

● Remove Line if Blank - if you have fields on one line and all the fields have no values, the entire 
line will be removed--space and all.  

● Print only when Expression is True – enter a condition the field must meet to be printed (e.g. 
only print if the field is not empty. You may use functions in your condition. For more 
information on functions, see the section ‘Adding Functions to Reports’. 

Adding Non-Printing Notes 

You can also create non-printing notes on reports that are displayed in modify mode but don't print 
on the report (e.g. editing instructions). To do so: 

1. Use the text tool to enter the desired note. 

2. Double-click the text entry to open the TEXT Window; then click the PRINT WHEN button.  

3. In the Print only when expression is true expression box, enter .F. (false).  

Creating and Using Variables 
Variables are used to compare and manipulate data for display in a report. Variables are not saved 
to the database--their values are stored in the computer's memory while the report is running. After 
you exit the report, the variables are erased from memory.  

You can use variables to: 

● Generate record counts in a report (e.g. how many individuals took courses during a given 
semester). 

● Generate numbered lists (e.g. 1. First person taking course, 2. Second person, etc.). 

● Calculate values based on report data (e.g. add the payment amount to the total paid IF the pay 
type is Cash).  

● Create shorthand representations of long expressions (e.g. variable Due represents the function 
gtdue(rgcrse,rgid) and variable Paid represents gtpaid(rgcrse,rgid)). 

● Calculate values then use those values to calculate subsequent values (e.g. Due-Paid). 
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To create a variable, select Report > Variables. On this screen, you can add new variables, change 
or delete existing variables or change the order in which the variables are evaluated in a report. The 
Variable Definition dialog offers these options:  

a. Variables: Name of the variable. 

b. Value to store: Field/Expression which should 
be stored/calculated in this variable. 

c. Initial value: Initial value of the variable 
BEFORE any calculations are performed 

d. Release after report: Clears the report variable 
from memory after the report is printed. If not 
checked, the variable remains in memory until 
you exit Student Manager. 

e. Reset at: Specifies the point at which the 
variable is reset to its initial value. End of 
Report is the default. Other options include 
End of Page, End of Column and groups you 
have created in the report. 

f. Calculate: Specify a calculation that the 
variable performs. The variable begins 
calculating with its initial value, and continues 
until it is reset. 

Variable Creation Notes 

● Report variables are evaluated in the order that they appear in the list and can affect the value of 
expressions that use them. For example, if variable 1 is used to define the value of variable 2, 
variable 1 must appear before variable 2.  

● If you use a variable in calculations, be sure that you initialize the variable with a non-zero value 
to avoid a division-by-zero error. If you don't specify a value, Visual FoxPro assigns a default 
value of 0. 

● If you reorder the groups in your report, your report variables might not be resetting on the 
correct field. For example, if your report has two groups, the first grouping by country and the 
second grouping by date, and you switch the order of the groups, the variables still reset 
according to the original positions of the groups. 

Calculations 
Click the Calculate button to set field calculation options. The most common settings are the ‘Count’ 
and ‘Sum’ options. The other choices are unreliable at best. Even the count and sum can be tricky 
if improperly used. Calculations work best on reports where there is only one line of information in 
the report cursor per group (e.g. one line per course, one line per registration, etc.).  

You may reset the calculations on any group band created in the report, at the end of each page, or 
at the end of the report. For example, if you have a field which calculates the total amount of optional 
fees per individual, you would reset every time the RGID field changes (sums optional fees for 
individual, then sets it to zero and resumes for next individual). .  
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Calculation Options 

Nothing - No calculations are made on this variable.  

Count - Counts the number of times a variable is printed per group, page, column, or report 
(depending on your selection in the Reset box). The calculation is based on the number of times the 
variable occurs, not on the variable's value.  

Sum - Sums the variable values for a group, page, column, or report (depending on your selection 
in the Reset box).  

Average - Computes the arithmetic mean (average) of the variable values within a group, page, 
column, or report (depending on your selection in the Reset box).  

Lowest - Displays the lowest value that occurred in that variable for a group, page, column, or report 
(depending on your selection in the Reset box). Places in the variable the value of the first record in 
the group. When a lower value is encountered, the variable's value changes accordingly.  

Highest - Displays the highest value that occurred in that variable for a group, page, column, or 
report (depending on your selection in the Reset box). Places in the variable the value of the first 
record in the group. When a higher value is encountered, the variable's value changes accordingly.  

Std. Deviation - Returns the square root of the variance for the variable values within a group, page, 
column, or report (depending on your selection in the Reset box).  

Variance - Measures the degree to which individual field values vary from the average of all values 
in the group, page, column, or report (depending on your Reset selection).  

Special Functions 
Some functions can only be used in a JUSTDOIT or a JUSTAFTER function. These are special 
functions that execute before or after a report runs.  

JUSTDOIT 

A JUSTDOIT is a specialized report function that uses SQL (Structured Query Language) to request 
and manipulate information from the data tables. With a JUSTDOIT, you can change the sort order 
of data in a report, filter out unwanted data, or execute specialized report functions. The JUSTDOIT 
executes the SQL commands BEFORE the report runs (before the data is displayed). 

The JUSTDOIT application in Student Manager uses the SQL SELECT command and its elements 
to manipulate the data. The following table provides an explanation of each element of the SELECT 
command: 

 
" ", ' ', [ ] Delimiters used to enclose the Select statement and other elements in the 

JUSTDOIT. 

select Tells the system to select specific data from the cursor. Immediately 
followed by a statement telling the system what data to select. 

* (asterisk) Tells the system to select ALL data from the table that follows the FROM 
statement (see below). 

as Creates a field in the cursor and enters data you specify into the records (i.e. 
enter a static value or use a report function to get value) 
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0 as marker Creates a field in the cursor and enters a zero (0) for every record in the 
cursor. This forces the JDI to run only once for a given report cursor (helps 
avoid circular logic problems). 

from  Tells the system where to get the data that you are manipulating with the 
JUSTDOIT. In most cases it will be from Cursor5 (default cursor created 
when the report opens). 

where States a conditional clause that data must meet to be included in the report 
(e.g. where due-paid > 0.00).  

group by Groups data in the cursor by the field you specify, then removes all but one 
record for each group.  

order by Changes the sort order of data in the cursor. NOTE: conflicting report 
banding will cause unexpected results. 

into cursor(cursor?) Tells the system to place the data back into the cursor once it has finished 
executing all the select statements, making it available for the Report Print 
Preview.  

 

The JUSTDOIT expression box may be placed anywhere on the report template but we recommend 
placing it in the header band of the report for purpose of quick identification. It's a non-printing 
element and will not display on the report itself.  

JUSTDOIT Examples 
● Change the Sort Order of Report with "Order By" Statement 

justdoit(‘select *,0 as marker from (cursor5) order by nmname3,nmname1 into cursor(cursor5)’) 

● Eliminating Duplicate records with the "Group By" Statement 
justdoit(‘select *,0 as marker from (cursor5) group by nmid,nmname3 into cursor(cursor5)’) 

● Filter the report with "Where" Statement 
justdoit(‘select *,0 as marker from (cursor5) where due-paid>0.00 into cursor(cursor5)’) 

● Add a field to the Cursor and then Sort by it 
justdoit(‘select *,addcrse(cocrse,"cobegdate") as date, 0 as marker from (cursor5) order by date 
into cursor(cursor5)’) 

JUSTDOIT Errors 
● A common problem in JUSDOITs is mismatched delimiters Errors occur when you don't use 

matching ones, or when you try to use the same pair more than once. 

BAD: Mismatched Quotes are used to enclose the Select statement (double quote at the 
beginning and single quote at the end).  

JUSTDOIT("select *,0 as marker from (cursor5) where nmzip ='55401' into cursor (cursor5)') 
 
BAD: Same Quotes are used for the Select statement and the value in the Where statement. 

JUSTDOIT("select *,0 as marker from (cursor5) where nmzip ="55401" into cursor (cursor5)") 

Note: occasionally you may need to use a third set of delimiters in a JUSTDOIT. In these cases, 
you may use the square Brackets [].  
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● Another common problem is leaving out the 0 as Marker statement. Without the statement, the 
JUSTDOIT may execute a random number of times or become stuck in an infinite loop. No real 
damage done, but your report results will be unexpected and inconsistent. 

● You cannot add a field to the cursor then attempt to do a comparison on the field contents in a 
Where statement. To accomplish this, you will need to add two JUSTDOITs to the report (see 
next section): 

Using Multiple JUSTDOITs 
You may occasionally find that you need to use more than one JUSTDOIT to accomplish your goal. 
For instance, if you want to add a field to the cursor then filter records based on the field contents.  

To accomplish this, you will need to add two JUSTDOITs to the report. In the first one you add the 
field to the cursor. In the second one, you use the Where statement to filter the records:  

justdoit(‘select *,addname(nmid,"nmocc") as Occupation from (cursor5) into cursor(cursor5)’) 

justdoit('select *,0 as marker from (cursor5) where Occupation="MED" into cursor (cursor5)') 

Notes:  
When using more than one JUSTDOIT in a report, you only put the 0 as Marker statement in the 
last JUSTDOIT. If you place it in both JUSTDOITs, the second one will be ignored (it will not be 
executed). 

Also, the JUSTDOITs must be added to the report in the correct order. For instance, if you add the 
Where Statement JUSTDOIT first and the Add Field one second, the system will execute the Where 
statement first because that was the one that was added to the report first, and you will receive an 
error because the field you are using in the Where statement doesn't exist yet.  

Recycle Query Mode 
If you are using the Recycle Query option and you run a report with a JUSTDOIT in it, you should 
leave the Recycle Query mode after running the report (i.e. click the EXIT button on the JUSTDOIT 
Warning window).  

The reason for this is that the JUSDOIT changed the cursor and the changes will be applied to all 
subsequent reports you run in the area until you exit the Recycle Query mode. 

JUSTAFTER 

A JUSTAFTER is a specialized report function that allows you to stamp a value in a field, extract 
fields to an external file, or execute specialized report functions AFTER the report runs. Like the 
JUSTDOIT, the JUSTAFTER is a non-printing element that we recommend placing in the header 
band.  

JUSTAFTER Examples 
● JUSTAFTER('=CONFIRM()') stamps system date into Confirm field on the Registration screen. 

Use it to log the date confirmation letters were sent to registrants. 

● JUSTAFTER('=NAMEEXP ("c:\myfile.dbf")') exports name and address information to a file 
called myfile.dbf on your hard drive (dBASE III format). This is most commonly used to create 
a mailing address file for Mailing Houses. 

● JUSTAFTER('=DOEMAIL()') starts the Mass Email Wizard after the report runs. This is most 
commonly used to email everyone in a report (e.g. receipts, confirmation, second notices, etc.). 
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APPENDIX A: KEYBOARD SHORTCUTS 
Activate Main Menu Items 

Alt+F = Activates File Menu 

Alt+E = Activates Edit Menu 

Alt+M = Activates Module Menu 

Alt+R = Activates Reports Menu 

Alt+T = Activates Tools Menu 

Alt+H = Activates Help Menu 

Alt+G = Activates Module > Registrations Menu 

Alt+P = Activates Module > Pocket Ledger Menu 

Alt+S = Activates Reports > Statistics Menu 

Student Manager Actions 
F1 = Show List of Student Manager shortcut keys 

Ctrl+U = Shows who is logged into Student Manager (Tools > Show Users) 

Ctrl+B = Checks for Student Call Backs (Tools > List Student Callbacks) 

Alt+K = Checks for Instructor Call Backs (Tools > List Instructor Callbacks) 

Ctrl+E = Opens System Information window (Help| About Student Manager) 

Alt+Q = Exits Student Manager (File > Quit) 

Alt+1 = Opens course Mass Change/Update/Delete/Archive screen. 

Module Shortcuts 
Alt+C = Opens new Course record (Module > Courses > Add Course) 

Alt+J = Opens Find Course window (Module > Courses > Find Course) 

Ctrl+K = Opens Find Active Course window (Module > Courses > Find Active Course) 

Alt+A = Opens new Name record (Module > Names > Add New Name) 

Alt+L = Opens Find Names window (Module > Names > Lookup Name) 

Ctrl+F = Opens Find Firm window (Module > Firms > Find Firm) 

Alt+I = Opens new Faculty Manager record (Module > Faculty > Add Instructor) 

Ctrl+I = Opens Faculty Manager Find window (Module > Faculty > Find Instructor) 

Alt+Z = Starts Speed Registration Entry routine (Module > Registrations > Speed Registration 
Entry)  

Alt+O = Opens Find Outstanding Invoices window (Module > Invoices > Outstanding Invoices) 

Course Record Shortcuts 
Alt+3 = Copies code, title, dates, instructor(s) names, time, description, location, and main 
registration fee from the open Course record to the Clipboard (for recalling into a document, e.g. 
letter, email, etc.) 

Ctrl+T = Copies all of the email addresses of students in the course, separated by semicolon, onto 
your clipboard (for pasting into an email client or document, etc.) 
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Faculty Record Shortcuts 
Alt+3 = Copies name, title, firm, address, day phone, and email address (in block format) from the 
open Faculty record to the Clipboard (for recalling into a document, e.g. letter, email, etc.) 

F3 = Faculty Talent Search 

Name Record Shortcuts 
F5 = Find Names Tool 

Alt +0 (Zero) = Manually edit the City and State 

Alt+3 = Copies name, title, firm, address, day phone, and email address (in block format) from the 
open Name record to the Clipboard (for recalling into a document, e.g. letter, email, etc.) 

Alt+F9 = Shows payment history of individual (can also be ran from Registration screen) 

Alt+F12 = Opens Log CRM Entry screen 

Alt +W = clones current Name record (Edit > Clone Name)  

Alt+V = pastes data from cloned record into open Name record (Edit > Paste Name) 

Alt+Y = create an Instructor record from the open Name record 

Shift+F5 = Opens Blacklist 

Shift+Alt+P = ACEweb Users Only: blanks the Password field 

Firm Record Shortcuts 
Alt+3 = Copies firm name, contact, address, and phone (in block format) from the open Firm 
record to the Clipboard (for recalling into a document, e.g. letter, email, etc.) 

Registration Record Shortcuts 
F4 = Find Registrations Tool 

F8 = Mass Group Registrations 

Alt+4 = Switches between open and validated Fee Adjustment Descriptions 

Alt+F9 = Shows payment history of individual (can also be ran from Names screen) 

Ctrl+F12 = Registration Import Wizard 

Screen Shortcuts 
Tab = Move FORWARD through fields 

Shift +Tab = Move BACKWARD through fields 

Esc = Escape screen WITHOUT saving changes; escape Find window WITHOUT selecting record 

Ctrl+A = Selects all data in a field 

Ctrl+Z = Undo 

Ctrl+X = Cut 

Ctrl+C = Copy 

Ctrl+V = Paste 

Ctrl+Y = Deletes characters from where the cursor is to the end of the field 

Ctrl+Left Arrow Key = Moves the cursor to the front of next word in a field 

Ctrl+Right Arrow Key = Moves the cursor to the front of the previous word in a field  

Home = Moves to the beginning of a field 
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Screen Shortcuts Continued 
End = Moves to the end of a field 

F4 = Opens drop down list 

Open Report Shortcuts 
Ctrl+M = Mailing Labels (Reports > Demographics > Mailing Labels) 

Ctrl+P = Names w/codes (Reports > Demographics > Names w/code) 

Alt+D = Deadbeat (Reports > Accounting > Special 1 Reg/1 Line [Deadbeat]) 

Ctrl+R = Name Roster (Reports > Registrations > Rosters > Name Roster) 

F2 = Quick Count Enrollment Report 

Ctrl+F2 = Quick Room Use Report  

Ctrl+F3 = Course Packaging Report Area 

F7 = Pay Grabber Report 

F9 = Student Manager Dashboard 

F10 = Membership Retention Wizard 

F11 = Attendance Tracker 

F12 = Financial Aid Reporter 

Report Designer Shortcuts 
Ctrl+I = Preview Report 

Ctrl+F4 = Close the Modify Report screen 

Special Action Shortcuts 
Alt+F1 = Repeats last Course Code entered in Query, last course record edited, or last registration 
added 

Alt+F2 = Repeats last text value entered into a query field 

Shift+F2 = Stamps current date into a date field 

Alt +F3 = Recalls user message/data into field (enter message on Edit > My User Profile screen) 

Alt+F4 = Recalls user message/data into field (enter message on Edit > My User Profile screen) 

Alt+F5 = Recalls user message/data into field (enter message on Edit > My User Profile screen) 

F6 = Resets system to recover from error. NOTE: any unsaved changes will be lost 
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APPENDIX B: REPORT AREA GUIDE 
The following tables list the reporting area and the databases the report area accesses.  

ACCOUNTING 

REPORT DATABASES 
Cash Drawer 
➢ Receipt Listing 
➢ Refund Listing 
➢ Cash Box Reconciliation 

Names, Course, Crseudfs, Pay 

Daily Income by Source (by Date) Register, Pay, Course, Names 
Daily Income By Source (by Course) Register, Pay, Course, Names 
Enrollment & Income Course, Grouping 
Income Detail By Registrant Register, Course, Names, Pay 
Special 1 Reg/1 Line Names, Register, Course, Location 

DEMOGRAPHICS 

REPORT DATABASES 
Names (with Codes) Names, Firms, Nameudfs, Namecode 
Names (with Registrations) Course, Register, Names, Nameudfs 
CRM Info CRM, Names 
Mailing Labels Names, Firm, Nameudfs, Register, Testing 
Credentials Names, Nameudfs, Testing, Firms, 
Firms (w/ Employees) Namecode, Nameudfs, Names, Firms 
Firms (w/o Names) Firm 
Firms (w/ Registrations) Course, Register, Firms, Names, Regfees 

COURSES 

REPORT DATABASES 
CEU Reporting Course, Crseudfs, Location 
Course Details (w/ Fees) Course, Location, Grouping, Fees, Crseudfs 
Room Use List 
➢ Date Sort 
➢ Location Sort 

Course, Location, Crsroom 

Waitlists Register, Names, Course 
Income Summary Course, Grouping, Crseudfs, Location, Linkinst, Instruct, Fees 
Generate Catalog Copy Catalog, Course, Location, Crseudfs, Instruct 
Attendance Attend, Course, Names, Register 
Course Packaging Course, Crsepack, Names, Register, Regudfs, Pay 

INVOICES 

REPORT DATABASES 
Run Invoices Names, Course, Pay 
Run Aging Report Names, Course, Pay 
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REGISTRATIONS 

REPORT DATABASES 
Registrations (w/Fees & Payments) Register, Course, Pay, Names, Regudfs 
Counts of Optional Fees Register, Regfees, Names, Course 
Receipts Firm, Names, Course, Register, Pay, Regfees, Location 
Rosters  
➢ Name Roster 
➢ Attendance Roster 

Names, Namudfs, Firm, Register, Course, Regfees, Location, 
Regudfs, Pay 

Transcripts Names, Register, Course 
Name Tags Names, Nameudfs, Register, Course 
Certificates Names, Register, Course, Location 
Tabletents Names, Nameudfs, Register, Course 

FACULTY REPORTS 

REPORT DATABASES 
Contract Agreements Instruct, Course, Linkinst, Firm, Location 
Instructor List Instruct, Course, Linkinst, Firm, Location 
1099 Form Instruct, Course, Linkinst, Firm, Location 
Performance Data Instruct, Course, Linkinst, Firm, Location 
Check Request Instruct, Course, Linkinst, Firm, Location 
Faculty Only Reports Instruct, Course, Linkinst, Firm, Location 
Faculty CRM Instruct, Course, CRM, Firm, Linkinst, Namecode 

POCKET LEDGER REPORTS 

REPORT DATABASES 
Expense Listing 
➢ Cost Center Grouping 
➢ Expense Class Grouping 
➢ Account # Grouping 
➢ Vendor Grouping 

Ledgentr, Leddesc, Firm 

Income/Expense Balances 
➢ Detail 
➢ Summary 
➢ Snapshot 

Ledgentr, Leddesc, Firm 

Budget Reports Ledgentr, Leddesc, Firm 

WORKSHOP REPORTS 

REPORT DATABASES 
Rosters/Certificates Wkshpmst, Courses, Names, Register, Wkshpind 
Enrollment Summary Wkshpmst, Courses 

STATISTICAL REPORTS 

REPORT DATABASES 
Names Demographic Sorting Courses, Names, Register, Namecode, Nameudfs 
Names Performance Sorting Courses, Names, Register, Namecode, Nameudfs 
Firms Represented Firm, Register 
Tracking Codes Names, Register 
Course Data Summary Courses 
Course Performance Review Courses 
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APPENDIX C: DATABASE MAINTENANCE 

Pack/Reindex 
At times you may need to rebuild the database indexes to insure optimal performance. You will also 
want to regularly remove the records that have been marked for deletion. To run the Pack/Reindex 
routine:  

1. Confirm that all other users are logged out of Student Manager. To do this, select Tools > Show 
Users. The system will check for other users logged into the system and display the information 
for you:  

 
2. Once you’ve confirmed that everyone else has logged out, select Tools > Database Admin > 

Pack/Reindex. This opens the PACK/REINDEX window.  

 

While you may choose individual databases to reindex/pack by double-clicking them, most of the 
time you’ll want to check ‘Select All Files. If you also want to remove all records that have been 
marked for deletion, check ‘Pack’. Then click the RUN button to start the process.  

The length of time it takes to reindex/pack depends upon the number of records in your database, 
the network speed, and the speed of your machine.  

Note: if you are running the SQL version, you can only reindex some system tables.  
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Backing Up Student Manager Data 
The Backup tool is only available with the VFP version (not available for the SQL version). 

The loss of important data ranks as the greatest fear of most computer users. Recovery, if possible 
at all, can cost you precious time and money. Backing up your data regularly is vital insurance 
against such a "data catastrophe". And we've made it easy to backup your Student Manager data. 
Just follow these steps: 

1. Get everyone else out of Student Manager. 
2. Select Tools > Backup Data.  
3. Enter the appropriate information then click 

the Continue button to start the backup 
procedure.  

 
Note: if you are accessing Student Manager with 
a UNC path (UNC paths start with 2 slashes [e.g. 
\\ce\manager6\]. Mapped paths start with a drive 
letter [e.g. F:\manager6\]. To find out which type 
you are using, select Help > About Student 
Manager and look at the Data Path entry.), this 
routine will not work for you.  

 

 

How Often Should You Backup Data? 

The question to ask yourself is: how much data am I willing to recreate if my system crashes? If 
you're adding or modifying a great amount of records on a daily basis, then you will want to consider 
a daily backup. If you work with Student Manager less frequently, then you can consider backing 
up once or twice a week.  

Backup Notes 

● The Backup routine will NOT recognize paths with spaces in them, e.g. f:\Student Manager 
Backup\. Please back up to a folder with no spaces in the name, e.g. f:\ACEback\. 

● The Backup routine will NOT recognize UNC paths, e.g. \\servername\backupfolder\. You must 
be running Student Manager from a mapped drive, e.g. f:\ACEback\, to use the built-in backup 
routine. 

● The Backup routine will ONLY back up Student Manager data and log files. It will NOT backup 
images or files you have stored in the Student Manager folder (e.g. images you use on reports 
or files you are attaching to confirmation emails). 

● We strongly encourage you to save your backup file to a location that is not on the Student 
Manager server. Or at the very least, to make a copy of the zip file after it's created and move it 
to a different server/machine. This ensures you have a backup of your data should the Student 
Manager server hard drive become corrupted or otherwise destroyed. 
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Combining Name Records 
Despite your best efforts, you may find that two records exist for the same person (e.g. one with a 
computer generated ID and one with a SSN, or one with an correct SSN and one with an incorrect 
SSN). In these cases, you can combine the information and all associated registrations from both 
records into one. To combine two records: 

1. Open the record you want to keep and write down the SSN/ID #.  

2. Open the record you want to delete and replace the SSN/ID # with the SSN/ID # of the record 
you want to keep. 

3. The system will ask you to confirm the SSN/ID # change. Click the YES button.  

4. You’ll be warned that the SSN/ID # has been assigned to someone else. Click the COMBINE 

NAMES button.  

5. The system will ask you to confirm your intent to combine records. Click CONTINUE. 

Duplicate Registrations 

If the individual is enrolled in the same class under both names, you will not be able to combine the 
records until you delete the duplicate registration and associated payments. 

Combining Records in Other Databases 

You can also combine records in the following databases using the specified ID field: 

● Faculty Records – use the Faculty System ID when combining records. 

● Firm Records – use the Firm ID field when combining firm records.  

● Location Records – use the Room Record Internal ID when combining records.  

● Code Records – use the Code when combining records. 

Updating Zip Codes 
ACEware Systems, Inc. releases a Zip Code Update file yearly (usually in the summer). Full 
instructions to update your zip codes are in the Reference Guide in the Maintenance Tools section.  

Updating Area Codes 
ACEware Systems, Inc. also offers an Area Code Update Utility that allows you to update area 
codes on existing Name records. Full instructions to update area codes are in the Reference Guide 
in the Maintenance Tools section.  

Upgrading Student Manager 
ACEware Systems, Inc. frequently adds new features and makes them available to our customers 
through download from our Student Manager Resources web page:  

https://www.aceware.com/customers/smresources.shtml 
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Deleting Additional Reports 
You have the ability to delete Additional Reports that you don't use. To do so: 

1. Select Tools > Reports > Delete Additional Report.  

2. Select the Sort Option: 

● View-Natural Order – sorts reports by record number (e.g. newest reports at the bottom).  

● View-Name Order - sorts reports by Report Name (or Report Area).  

3. The list of Additional Reports opens.  

4. Check the box next to the report you want to delete.  

5. Click the DONE button.  

Deleting during Report Modification 

You also have the ability to delete an additional report* when saving modifications to it. This is 
most useful if you've made a test report that you now want to delete. However, you can also use it 
to preview additional reports and delete those you don't want.  

To delete a report while in Modification mode: 

1. Close the REPORT MODIFICATION screen by selecting File > Close or by using the shortcut 
key: Ctrl+F4.  

2. Click the YES button on the SAVE CHANGES window.  

3. The Saving Modifications window opens. To delete the report, click the DELETE button.  

 
4. Confirm the delete procedure by clicking the YES button on the Confirmation box.  

5. Click the DONE button to close the Saving Modifications window.  

6. The report is marked for deletion and will be removed when you Pack the system. 

*You CANNOT delete a default report. 
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TRAINING EVALUATION 
Please take a few minutes to give us feedback on your training session. Your comments are greatly 
appreciated and will be used in development of future training sessions.  

Please check the box that most closely reflects your opinion on each evaluation item. If you select 
Disagree or Strongly Disagree, please clarify your response in the space provided. 

Content Strongly 
Agree 

 
Agree 

 
Disagree 

Strongly 
Disagree 

Training guide was organized and easy to follow.     
Training objectives were relevant and useful.     
Adequate time was spent on each training objective.     
Objective exercises helped develop skills.     

Please clarify your answer(s), if necessary:  
 

 

 

 

Instructor Strongly 
Agree 

 
Agree 

 
Disagree 

Strongly 
Disagree 

Identified and followed training objectives.     
Had a thorough knowledge of the subject matter.     
Was courteous and helpful.     
Encouraged/answered questions.     

Please clarify your answer(s), if necessary:  
 

 

 

 

Overall Strongly 
Agree 

 
Agree 

 
Disagree 

Strongly 
Disagree 

The training session met my expectations.     
I will be able to apply the knowledge learned.     
I would recommend this training session to others.     

Please clarify your answer(s), if necessary:  
 

 

 

 

Please see reverse side for Comments section.  
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Comments 
1. What was the most valuable aspect(s) of the training session? 
 
 
 
 
 
 
 
2. What was the least valuable aspect(s) of the training session? 
 
 
 
 
 
 
 
3. Were there topics/issues that you wished had been covered during the training session? 
 
 
 
 
 
 
 
4. Are there other training sessions you would like to see ACEware offer in the future? 
 
 
 
 
 
 
5. Additional Thoughts/Comments/Suggestions? 
 
 
 
 
 
 
 
6. Optional:  
 
 
 
 
 

Name:   Date:   



 

 



 

 

 

 
ACEware Systems, Inc. 

121 S 4th Street, Ste. 205 

Manhattan, KS 66502 

800-925-2493 voice ● 785-537-6811 fax 

info@aceware.com ● support@aceware.com 

www.aceware.com ● www.aceware.com/smhelp 

 

 

 

 

 

Resources 
ACEware Website: www.aceware.com 

Online Help: www.aceware.com/smhelp 

Student Manager Resources: www.aceware.com/customers/smresources.shtml 

ACEweb Resources: www.aceware.com/customers/awresources.shtml 

ACEware Newsletter Archive: www.aceware.com/company/newsletterarchive.shtml 

ACEware Webinar Archive: www.aceware.com/webinars/ 

Training Options: www.aceware.com/events/trainOptions.shtml 


